Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Web address line autofill

  • 3 replies
  • 2 have this problem
  • 3 views
  • Last reply by cor-el

more options

Whenever you start typing a certain website name in the address bar, Firefox suggests and option to auto-fill the address based on what you've typed. My issue with that is that auto-fill keeps suggesting the address that I DON'T want it to. Specifically, I want "ya" to auto-fill to "ya.ru", instead it keeps suggesting "yandex.com.ge". Now, I have tried deleting all the history of ever going to "yandex.com.ge" as well as just ignoring the issue and typing out the full "ya.ru" by myself and giving Firefox some time to catch onto this, however after a couple of weeks nothing's changed. What's interesting is that when I type "ya" in the address bar, Firefox shows the following (in order): the wrong auto-fill suggestion ("yandex.com.ge"), some search suggestions (yahoo, yandex, yahoo mail, etc), then after the search suggestions there is a separator that says "Firefox suggests" and what do you think, the CORRECT auto-fill that I want is first right in there - "ya.ru". So Firefox actually knows that I want it, since it's the first thing in "Firefox suggests", but why can I not get it as a default auto-fill suggestion?

Whenever you start typing a certain website name in the address bar, Firefox suggests and option to auto-fill the address based on what you've typed. My issue with that is that auto-fill keeps suggesting the address that I DON'T want it to. Specifically, I want "ya" to auto-fill to "ya.ru", instead it keeps suggesting "yandex.com.ge". Now, I have tried deleting all the history of ever going to "yandex.com.ge" as well as just ignoring the issue and typing out the full "ya.ru" by myself and giving Firefox some time to catch onto this, however after a couple of weeks nothing's changed. What's interesting is that when I type "ya" in the address bar, Firefox shows the following (in order): the wrong auto-fill suggestion ("yandex.com.ge"), some search suggestions (yahoo, yandex, yahoo mail, etc), then after the search suggestions there is a separator that says "Firefox suggests" and what do you think, the CORRECT auto-fill that I want is first right in there - "ya.ru". So Firefox actually knows that I want it, since it's the first thing in "Firefox suggests", but why can I not get it as a default auto-fill suggestion?

All Replies (3)

more options

Same problem here with gmbinder.com replacing gmail.com, very frustrating, no option but to disable autofill in about:config since the ... option doesn't exist for some reason.

more options

To be honest, I don't understand how those in-URL-bar autofill suggestions are prioritized. Sometimes I think it's alphabetical, but that clearly is not the case with gmb before gma.

There is a hidden way to turn off these autofill suggestions; I'll mention that below the line. There also is work underway to expand autofill suggestions to full URLs if you visit those more frequently than the top level of a site. Not sure how soon that will be finished.

Bookmark Keyword Option

Aside from finding a way to make the current algorithm work for you, another option is to create your own "keyword" shortcuts for the address bar. That way, ya can load whatever URL you want. Here's how:

(1) Open the page you want to create a keyword for (2) Right-click the tab and choose Bookmark Tab... (3) Edit the Name as needed, change the Location if needed (4) Key step: In the Keyword box, enter the text you want to use as your shortcut (5) Click the Save button

Then test. In the top line of the drop-down, after you type the keyword, Firefox should tell you it is going to visit that bookmarked URL.


To completely disable in-URL-bar autofill

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.urlbar.autoFill and pause while the list is filtered

(3) Double-click the preference (or click the toggle switch toward the right end of its row) to switch the value from true to false

more options

Note that you can set browser.urlbar.showSearchSuggestionsFirst = false to move the Search Suggestions to the bottom.