Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to install unsigned extension despite following suggestions

  • 2 replies
  • 0 have this problem
  • 630 views
  • Last reply by cor-el

more options

Hello everyone, I wrote an add-on for my own personal use. I don't intend to publish it. So naturally, it isn't verified, but I trust it. I am able to install the add-on as a temporary add-on under about:debugging, and it works as intended. The manifest file contains "browser_specific_settings": {

       "gecko": {
           "id": "example@example.com"
       }

} I would now like to install the add-on permanently. So I packaged it as a zip file. The zip file contains the files directly without a parent folder. Under about:config I set xpinstall.signatures.required, xpinstall.whitelist.required and extensions.langpacks.signatures.required to false. Then I went to about:addons clicked on install add-on from file and selected the zip file. I got the error message: "This addon could not be installed because it has not been verified". I am using Firefox for archlinux, version 112.0.

What am I missing? How can I install this addon?

I apprechiate your answers.

Hello everyone, I wrote an add-on for my own personal use. I don't intend to publish it. So naturally, it isn't verified, but I trust it. I am able to install the add-on as a temporary add-on under about:debugging, and it works as intended. The manifest file contains "browser_specific_settings": { "gecko": { "id": "example@example.com" } } I would now like to install the add-on permanently. So I packaged it as a zip file. The zip file contains the files directly without a parent folder. Under about:config I set xpinstall.signatures.required, xpinstall.whitelist.required and extensions.langpacks.signatures.required to false. Then I went to about:addons clicked on install add-on from file and selected the zip file. I got the error message: "This addon could not be installed because it has not been verified". I am using Firefox for archlinux, version 112.0. What am I missing? How can I install this addon? I apprechiate your answers.

Chosen solution

You can get an extension signed for personal use by choosing not to make it available on the Add-ons website.

Read this answer in context 👍 1

All Replies (2)

more options

You can't do this with a regular release version, xpinstall.signatures.required is only supported on ESR and in developer builds (Developer Edition and Nightly).

xpinstall.signatures.required (Firefox ESR 102.10, Firefox ESR only)

Modified by cor-el

more options

Chosen Solution

You can get an extension signed for personal use by choosing not to make it available on the Add-ons website.