Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Titlebar Buttons missing, if running Firefox in CentOS7/Gnome, and accessed via RDP from Windows 10 Enterprise

  • 4 replies
  • 0 have this problem
  • 15 views
  • Last reply by cor-el

more options

My setup: A remote server running CentOS Linux 7 and Firefox Browser 102.7.0esr (64-bit), accessed via RDP from a Windows 10 Enterprise laptop (No tablet)

Up in the top right corner of the Mozilla Firefox window, I have only the close button, the Minimize and the Maximize buttons are missing. In the same gnome (desktop) environment, all other running windows has those buttons available.

Note: if toggle enable or disable those buttons “Minimize” & “Maximize” [command: gnome-tweaks > Windows > "Titlebar Buttons" > toggle] , all running windows in gnome will be affected correctly, except the Firefox window, with no impact. Reinstall Firefox did not help.

This behavior started after our latest yum update recently.

When connected locally to the Linux server, there are no issues, the buttons are available. (i.e., no RDP involved)

firefox-102.7.0-1.el7.centos.x86_64 xrdp-0.9.21-1.el7.x86_64

Any tip from the community?

Br. Peter

My setup: A remote server running CentOS Linux 7 and Firefox Browser 102.7.0esr (64-bit), accessed via RDP from a Windows 10 Enterprise laptop (No tablet) Up in the top right corner of the Mozilla Firefox window, I have only the close button, the Minimize and the Maximize buttons are missing. In the same gnome (desktop) environment, all other running windows has those buttons available. Note: if toggle enable or disable those buttons “Minimize” & “Maximize” [command: gnome-tweaks > Windows > "Titlebar Buttons" > toggle] , all running windows in gnome will be affected correctly, except the Firefox window, with no impact. Reinstall Firefox did not help. This behavior started after our latest yum update recently. When connected locally to the Linux server, there are no issues, the buttons are available. (i.e., no RDP involved) firefox-102.7.0-1.el7.centos.x86_64 xrdp-0.9.21-1.el7.x86_64 Any tip from the community? Br. Peter

Modified by P.M.swe

Chosen solution

Additional info, starting Firefox (firefox-102.7.0-1.el7.centos.x86_64) with cli "/bin/firefox 2>&1" will show:

Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName (t=2.14653) [GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName (t=2.14653) |[1][GFX1-]: Unrecognized feature ACCELERATED_CANVAS2D (t=7.35117) [GFX1-]: Unrecognized feature ACCELERATED_CANVAS2D Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs

However, doing as mentioned above, getting a version directly produced by Mozilla (firefox-61.0.tar.bz2) solved the issue, the Titlebar Buttons are back.

Thanks!

Read this answer in context 👍 0

All Replies (5)

more options

Hi

Instead of using the version from the repo, please can you try a version directly produced by Mozilla (the tarball, Snap or Flatpak)?

Does the same issue occur?

Helpful?

more options

Chosen Solution

Additional info, starting Firefox (firefox-102.7.0-1.el7.centos.x86_64) with cli "/bin/firefox 2>&1" will show:

Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName (t=2.14653) [GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: libEGL missing eglGetDisplayDriverName (t=2.14653) |[1][GFX1-]: Unrecognized feature ACCELERATED_CANVAS2D (t=7.35117) [GFX1-]: Unrecognized feature ACCELERATED_CANVAS2D Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs

However, doing as mentioned above, getting a version directly produced by Mozilla (firefox-61.0.tar.bz2) solved the issue, the Titlebar Buttons are back.

Thanks!

Modified by P.M.swe

Helpful?

more options

Oops sorry, firefox-61.0.tar.bz2 is of cause totally wrong version! Trying with version firefox-112.0b9.tar.bz2 instead, and unfortunately still problem.

But starting firefox as user root, the Titlebar Buttons are back.

Helpful?

more options

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Helpful?

more options

You can also try a different theme and icon pack in Linux.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.