Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error with homepage on Firefox 106 (Linux)

more options

I'm using Firefox browser v106 on Linux (Debian distribution on amd64).

My settings use "Firefox Home" (Web Search and Shortcuts) as Homepage. When I try to open a new page or tab, I have an error : "Oops, something went wrong loading this content. Refresh page to try again".

Despite my research, impossible to fix this issue. In Web Developer Tools / Console, I have the log : "TypeError : sectionOrder is undefined", in file resource://activity-stream/data/content/activity-stream.bundle.js

Have you any clue to fix this issue without resetting my Firefox profile ?

I'm using Firefox browser v106 on Linux (Debian distribution on amd64). My settings use "Firefox Home" (Web Search and Shortcuts) as Homepage. When I try to open a new page or tab, I have an error : "Oops, something went wrong loading this content. Refresh page to try again". Despite my research, impossible to fix this issue. In Web Developer Tools / Console, I have the log : "TypeError : sectionOrder is undefined", in file resource://activity-stream/data/content/activity-stream.bundle.js Have you any clue to fix this issue without resetting my Firefox profile ?

Chosen solution

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Read this answer in context 👍 1

All Replies (7)

more options

Yes, don't reset your profile. Could you take a look at the sectionOrder preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are checking/resetting, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.newtabpage.activity-stream.sectionOrder and pause while the list is filtered

On mine, running on Windows 10, there's a single match with this value: topsites,topstories,highlights

(3) Next step:

(A) If the preference has a Reset button (left-arching arrow) at the right end of the row, click that button to restore the default value for your build.

(B) If the preference has a blank value, consider assigning one: Double-click the preference to display an editing field, and change the value to topsites,topstories,highlights then press Enter or click the blue check mark button to save the change.

(C) If the preference doesn't exist -- Firefox shows a bar with Boolean Number String and a plus button -- this could indicate that your build has been modified from the default, maybe by your distribution. You could create a string preference with the above-reference value, but you might also check any forums your distribution maintains for Firefox.

Helpful?

more options

My configuration for browser.newtabpage.activity-stream.sectionOrder is properly defined : topsites,topstories,highlights (default value) by my problem persists even if i try to change it.

Modified by Laurent Cheylus

Helpful?

more options

This issue is with your distro version. Try downloading Firefox from Mozilla, unzip, and run firefox-bin from the folder and see if you have the same issue.

Modified by jonzn4SUSE

Helpful?

more options

No, my issue is not due to my distribution : my Firefox installation on my Linux desktop works well for years and is updated regularly with new version (Debian package).

This issue is certainly due to a corrupted file in my profile or an invalid setting but I can't find the cause of the error.

Modified by Laurent Cheylus

Helpful?

more options

I don't know what is the less drastic thing to suggest:

(A) Temporarily rename the prefs.js file (while Firefox is not running) to return most customized settings to defaults

(B) Reinstall Firefox (over the current installation, no uninstall needed) to refresh the program files in case there is code corruption or a version mismatch in the program folder

Helpful?

more options

Chosen Solution

You can try "Clear the startup cache..." via the "Help -> More Troubleshooting Information" (about:support) page.

Helpful?

more options

Thanks, my problem is resolved after "Clear the startup cache..." :)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.