Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Netflix saying, "Looks like your browser is no longer supported. Error Code F7121-3078" after latest Widevine update

  • 2 replies
  • 0 have this problem
  • 24 views
  • Last reply by James

more options

I have the latest version of Firefox 78.15.0esr (64-bit) on my Macbook Pro. Netflix says, "Looks like your browser is no longer supported. Please install the latest version or install another browser. Error Code F7121-3078" (see image 1).

Netflix streaming works fine on Opera, but I can't get it working on Firefox, even though it was working fine on Firefox a couple of days ago (Sept 15, 2022). Any help you can offer would be appreciated very much. I have two plug ins: Facebook Container and EFF Privacy Badger. There is no update available to update Firefox. It appears that when the new version of Widevine updated yesterday (see image 2), the browser stopped working for streaming on Netflix. Widevine version 4.10.2209.1 (updated Sept 16, 2022).

I have the latest version of Firefox 78.15.0esr (64-bit) on my Macbook Pro. Netflix says, "Looks like your browser is no longer supported. Please install the latest version or install another browser. Error Code F7121-3078" (see image 1). Netflix streaming works fine on Opera, but I can't get it working on Firefox, even though it was working fine on Firefox a couple of days ago (Sept 15, 2022). Any help you can offer would be appreciated very much. I have two plug ins: Facebook Container and EFF Privacy Badger. There is no update available to update Firefox. It appears that when the new version of Widevine updated yesterday (see image 2), the browser stopped working for streaming on Netflix. Widevine version 4.10.2209.1 (updated Sept 16, 2022).
Attached screenshots

Modified by ramseyrabie

All Replies (2)

more options

Helpful?

more options

If you had macOS 10.12 (ten.twelve)or later you would be able to use more current versions of Firefox.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.