Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox slow to boot [Arch Linux]

  • 4 replies
  • 0 have this problem
  • 101 views
  • Last reply by ashley92508

more options

Hi, so I recently installed arch Linux and want to use Firefox as my browser. However ever since I installed it, it takes a long time to launch the program. It consistently takes just over 26 seconds to launch. After it's open everything works fine besides that. Also when I launch Firefox from the terminal I get this message "ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs" I have been looking at some help threads but I can't make sense of what they are talking about. Hopefully this makes some amount of sense to you.

Hi, so I recently installed arch Linux and want to use Firefox as my browser. However ever since I installed it, it takes a long time to launch the program. It consistently takes just over 26 seconds to launch. After it's open everything works fine besides that. Also when I launch Firefox from the terminal I get this message "ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. Missing chrome or resource URL: resource://gre/modules/UpdateListener.jsm Missing chrome or resource URL: resource://gre/modules/UpdateListener.sys.mjs" I have been looking at some help threads but I can't make sense of what they are talking about. Hopefully this makes some amount of sense to you.

Chosen solution

Ill give this an update in case its able to help someone else. So I was able to find a solution. I added "exec dbus-update-activation-environment --systemd DBUS_SESSION_BUS_ADDRESS DISPLAY XAUTHORITY &" to my i3 configuration file and rebooted my system. Thanks again for your help

Read this answer in context 👍 1

All Replies (4)

more options

Hi

Are you using the version of Firefox from the Arch repo or from Mozilla?

I recommend trying to reproduce this issue in a version directly from Mozilla - https://www.mozilla.org/en-GB/firefox/all/#product-desktop-release

Helpful?

more options

I was able to replicate the issue with the firefox program installed from Mozilla's website. That being said while I was testing it, I installed a file manager (Thunar) and noticed it has the same 26 sec stratup. I ran it from the terminal and it gave me this error "ThunarThumbnailer: Failed to retrieve supported types: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.thumbnails.Thumbnailer1 was not provided by any .service files ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment. ATTENTION: default value of option mesa_glthread overridden by environment." which leads me to believe its actually an arch issue with certain programs and not an issue with firefox itself. If you know of a solution for this issue lmk. Otherwise, I can take this issue to a support team related to arch linux. Thank you

Helpful?

more options

No problem, glad we helped get you going in the right direction to get this resolved.

Helpful?

more options

Chosen Solution

Ill give this an update in case its able to help someone else. So I was able to find a solution. I added "exec dbus-update-activation-environment --systemd DBUS_SESSION_BUS_ADDRESS DISPLAY XAUTHORITY &" to my i3 configuration file and rebooted my system. Thanks again for your help

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.