Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure connection failed after password change

  • 13 replies
  • 1 has this problem
  • 26 views
  • Last reply by djsuson

more options

About two weeks ago I changed my google password. After I did that, Thunderbird on my primary computer (desktop running Slackware-64 Linux) required that I log into my gmail account again. I went through the steps of entering my email and password, successfully completed the 2-step verification. and gave permission for Thunderbird to access my account. Instead of dealing with my emails as usual, I got a "Secure connection failed" pop-up window. Two strange aspects to all of this: 1) when I did the same thing on my laptop (also running Slackware-64 Linux), everything went fine and I can deal with my gmail account, and 2) the URL at the top of the pop-up window is for my wife's company, clsusonenterprises.com (see attachment). I've tried searching the various forums on the web with no success. Any suggestions are welcomed.

About two weeks ago I changed my google password. After I did that, Thunderbird on my primary computer (desktop running Slackware-64 Linux) required that I log into my gmail account again. I went through the steps of entering my email and password, successfully completed the 2-step verification. and gave permission for Thunderbird to access my account. Instead of dealing with my emails as usual, I got a "Secure connection failed" pop-up window. Two strange aspects to all of this: 1) when I did the same thing on my laptop (also running Slackware-64 Linux), everything went fine and I can deal with my gmail account, and 2) the URL at the top of the pop-up window is for my wife's company, clsusonenterprises.com (see attachment). I've tried searching the various forums on the web with no success. Any suggestions are welcomed.
Attached screenshots

All Replies (13)

more options

Click the "Or you can add an exception" link at the bottom of the error page, but don't actually create an exception. Inspect the certificate - see the attached screenshot for instructions.

Who's the issuer of the cert? Does the cert's subject match the server you're trying to connect to? Is the cert still valid?

Please post a screenshot of the Certificate Viewer window with the above information visible.

Helpful?

more options

Unfortunately, clicking the "add exemption" line doesn't do anything; no response whatsoever. Any other thoughts? Should I try clearing my certificates?

Helpful?

more options

Is there anything related in the Error Console (Ctrl-Shift-J)?

Helpful?

more options

I watched the error log as I went through each screen. The change to the final screen (with the error message) resulted in the following entries:

- NS_ERROR_NOT_IMPLEMENTED: Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIRequest.name] - Content Security Policy: Ignoring \u201c'unsafe-inline'\u201d within script-src or style-src: nonce-source or hash-source specified - NS_ERROR_NOT_IMPLEMENTED: Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIRequest.name]

These don't yield any clues to me about the security failure. Please let me know if you have any ideas on how to proceed.

Helpful?

more options

What version of TB are you running?

Is this the vanilla TB version from https://www.thunderbird.net or a version provided by your distribution?

Does the problem occur in Troubleshooting Mode? https://support.mozilla.org/kb/troubleshoot-mode-thunderbird

Helpful?

more options

I am running TB version 91.4.1 . It was provided by Slackware Linux. It was downloaded and installed at the start of 2022. The problem persists even in troubleshooting mode.

Some additional information. I am able to create the account manually but it doesn't connect. The problem continues to be with the Google authentication. I get to the point where Thunderbird is asking for permission to access my Google account, hit allow, and then get the Secure Connection Failed window. Nothing I do gets past this.

Helpful?

more options

Did you try Troubleshooting Mode as suggested above?

Helpful?

more options

Yes, I tried Troubleshooting Mode. There was no difference in the behavior of TB with regards to this issue.

Helpful?

more options

Update on this problem - I tried removing my profile by renaming .thunderbird to .thunderbird-old and restarting thunderbird. It prompted me to go through the steps to add an account and again gave me the same secure connection failed error. Unless thunderbird is storing information outside of the .thunderbird directory then it appears that this problem is on the gmail end more than with thunderbird. I'll leave this thread open for now in case anyone else has an idea, but will also see if I can find a forum on the gmail side to pursue a resolution.

Helpful?

more options

What I really don't understand, you attempt to connect to your own account, but you do get a 'Secure connection failed' prompt for your wife's account?

There is nothing else I can suggest, other than try with a vanilla Thunderbird version from Mozilla. You can download the latest TB91 (currently 91.12.0) from https://ftp.mozilla.org/pub/thunderbird/releases/91.12.0/linux-x86_64/ Pick the locale you want (e.g. en-US), download the .tar.bz2 file (thunderbird-91.12.0.tar.bz2), and extract it. See https://support.mozilla.org/en-US/kb/installing-thunderbird-linux#w_installing-thunderbird-manually-for-advanced-users for instructions.

Note, downloading from https://www.thunderbird.net/ will get you TB102.1.1 which you may not want to use (yet) at this time. In case you do, make sure to create a full backup of your Thunderbird profile prior to the upgrade. https://support.mozilla.org/kb/profiles-where-thunderbird-stores-user-data#w_backing-up-a-profile

Helpful?

more options

Yeah, that's what tipped me off about something weird happening. Personally, I think it is something at Google in my record. I have posted a request for help on their gmail forum, but haven't seen anything yet. The weird thing (other than the redirect being wrong) is that I run pretty much the same setup (same Slackware Linux, same version of Thunderbird) on my laptop and it was able to reconnect to gmail without a problem. I'll try the vanilla version for completeness but I don't have a lot of hope for it. I'll wait to close this thread until I've tried that.

Helpful?

more options

This might be unrelated, but try changing the imap server to gmail.com from googlemail.com. Google stopped recommending googlemail servers about the time they left beta and some odd things have happened with oauth on googlemail servers..

Helpful?

more options

Matt said

This might be unrelated, but try changing the imap server to gmail.com from googlemail.com. Google stopped recommending googlemail servers about the time they left beta and some odd things have happened with oauth on googlemail servers..

@Matt - thank you for the suggestion. I tried this early on with no success. I'm fairly convinced that the problem lies with my google account and a bad entry in their database. Unfortunately, I never received any response from their support forums and there doesn't appear to be any way of talking with a human for technical support. I've set up alternatives for now and will tilt at this particular windmill again later.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.