Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

sending e.mails out

  • 24 replies
  • 1 has this problem
  • 18 views
  • Last reply by Toad-Hall

more options

I have installed Thunderbird and logged in via Google account and I have no problems with receiving e-mails, unfortunately sending out does not work. Somebody told me to choose OAuth2 but this option does not exist for the "sending out" server. My email is on gmail. What to do? Witoldrem

I have installed Thunderbird and logged in via Google account and I have no problems with receiving e-mails, unfortunately sending out does not work. Somebody told me to choose OAuth2 but this option does not exist for the "sending out" server. My email is on gmail. What to do? Witoldrem

Chosen solution

You have something really messed up in your preferences. This probably all stems from when you edited the outgoing smtp and set up an incorrect server name. Even though it was corrected in Account Settings, I bet the 'prefs file still uses soemthign incorrect, but deleting all those files should have corrected that problem. Why you have a load of appended data in an outgoing file - not sure what you did. I do recognise the data .

I would create a new profile and add the gmail account. How to create a new Profile:: click on 'Help' and you will see a drop down list - click on 'More TRoubleshooting Information' Under 'Application Basics' - near the bottom see 'Profiles' - click on 'about:profiles' It opens in a new tab. This shows you your list of profiles. Near the top - click on 'Create a new Profile' Click on 'Next' Enter a new profile name: Default User Click on 'Finish'

That 'Default User' profile will now get added to the list of Profiles. It will say: Profile : Default User Default Profile: No Root Directory:C:\Users\User name\Roaming\Profiles\profile name.default user Local Directory: C:\Users\User name\Local\Profiles\profile name.default user

Below will be some buttons. Click on 'Set as default profile' Click on 'Launch Profile' It opens in a new window

Close/Exit the original Thunderbird window and start to use the new Thunderbird window.

If you do not see 'File', Edit, View etc because top menu is not visible: Press 'Alt' key and it will appear - then quickly use 'View' > 'Toolbars' > select 'Menu Bar'

File > New > Existing Mail Account Enter name Enter full gmail email address Enter password Select checkbox 'Remember password' Click on 'Continue' It will auto look for IMAP settings.

Check it has got settings correctly - click on 'Configure Manually' Make sure 'Authentication Method: is set up as 'OAuth2' for both incoming imap and outgoing smtp. If all is ok then click on 'Done'

You will get prompted by google to enter email address and password and then OAuth token is created.

Read this answer in context 👍 0

All Replies (20)

more options

Oauth2 is in Authentication Method list for the outgoing server SMTP.

Right click on gmail account name folder in Folder Pane and select 'Settings' In Account Settings In left pane scroll to bottom and click on 'Outgoing Server (SMTP)' On the right select the gmail smtp server. If you have more than one gmail account, look for the gmail smtp server where the 'User name' = email address of problem account.

If it does not exist then click on 'Add' If you see it then click on 'Edit'

Description - enter the same email address as you see entered for User name You should be using these settings:

  • Server name: smtp.gmail.com
  • Port: 465
  • Connection Security: SSL/TLS
  • Authentication Method: OAuth2
  • user name: full email address

Click on OK

then make sure your gmail account is using that smtp server. select the gmail account name in left pane bottom right locate the Outgoing Server SMTP If it is not displaying that accounts email address (you entered it in the Description so it should show): click on the drop down (DO NOT click on the 'Edit Server_SMTP' button) and select correct gmail smtp server that shows the email address.

Exit Thunderbird, wait a few moments and then restart Thunderbird.

Images below as a guide just to show you the areas I'm talking about.

more options

Thank you for your answer. Unfortunatelu everything looks differently onmy screen. On the lis of the authentication methods OAuth2 does not exist. There aren only 5 options: without authentication, simple password, coded password, Krrberos adn NTML Print screen enclosed.

more options

re :I have installed Thunderbird

What version of Thunderbird are you using ? Did you download a windows 32bit or windows64bit ?

What Operating System are you using ? Windows ? Linux ?

Did you get the download from the official website : https://www.thunderbird.net/en-US/thunderbird/all/#P

I'm presuming it is Polski (Polish) language.

Modified by Toad-Hall

more options

On closer inspection, the image you posted has wrong settings.

Nazwa serwera: smpt.gmail.com - this is wrong. The p and t are wrong way around. Nazwa serwera: smtp.gmail.com - it should say this.

When you enter correct smtp server name, it should offer the OAuth2 option.

Uzytkownik: please check this because there is a space in the name - but maybe it should be a dot?

If you do not see the OAuth option , clickon OK so it saves the correct server name and then try editing again to see the OAuth option is now appearing.

Modified by Toad-Hall

more options

Yes, when i corrected the name of the outgoing server Auth2 appeared, I have chosen this option and tried to send a message. Without effect. This time the system suggests that I have given a wrong password. I am sure the password was correct but even not, I have no possibility to enter it once again. They say try again and no field to enter tha password appears.

My windows is 64 bit, and my Thunderbird is new 91.10.0 (64 bites). You are right, I am Polish.
more options

Yes, when i corrected the name of the outgoing server Auth2 appeared, I have chosen this option and tried to send a message. Without effect. This time the system suggests that I have given a wrong password. I am sure the password was correct but even if not, I have no possibility to enter it once again. They say try again and no field to enter tha password appears.

My windows 10 is 64 bit, and my Thunderbird is new 91.10.0 (64 bites). You are right, I am Polish.

more options

re :Yes, when i corrected the name of the outgoing server Auth2 appeared,

That's good to know, so at least that part is now working.

re :This time the system suggests that I have given a wrong password.

OK. It makes you wonder whether the 'normal password' got saved and for some crazy reason it is being used instead of the 'token'

  • Menu app icon ≡ > Preferences > Privacy and Security
  • Under 'Passwords' section
  • Click on 'Saved Passwords'

You should see line begining with 'oauth://accounts.google.com (https://mail.google.com/) - this is ok

If you see lines that start with mailbox://(if pop), imap:// (if imap) and smtp:// where username = gmail address example:

  • Select the mailbox://(if pop), imap:// (if imap) and smtp:// lines for the gmail address/username and click on 'Remove'.
  • then click on Close

Exit Thunderbird, wait a few moments then restart. Now there is only an oauth token stored. Test sending.

more options

I can see the following two identical lines:

oauth://accounts.google.com (https://mail.google.com/ https://www.googleapis.com/auth/carddav https://www.googleapis.com/auth/calendar)

and there is nothing I can do in this window

more options

So I presume they are the only lines you see. There are no other lines eg: smtp:// for the gmail account. If yes, that is ok.

See if the Windows cache is messing things up.

Exit Thunderbird. Access this location:

C:/Users/User Account/Appdata/Local/Thunderbird/Profiles/

In the 'Profiles' folder - Delete the 'profile name' folder.

Please note you must be in the Appdata 'Local' folder - not the 'Roaming' folder as that contains your profile and emails. You do not want to delete anything in the 'Roaming' folder.

You can get to the Appdata folder by doing the following: In bottom search type : %Appdata% and select the 'Appdata' app option Then you can click on 'Local', then 'Then 'Thunderbird' and finally 'Profiles'

See image below as guide.

Start Thunderbird.

more options

In my computer instead of C:/Users/User Account/Appdata//Local/Thunderbird/Profile / only C:\Users\user\Application Data\Microsoft exist.

more options

I have carried out the procedure again, the screens are shown below,. Do I really have to delete the whole Profile ?

more options

The images show you are in the correct place - local. You can delete all the contents of the 'profile name' folder or the 'profile name' folder - both methods will be ok. When you restart Thunderbird it will regenerated.

more options

OK, I have deleted the PROFILE, restarted Thunderbird, the Profile appeared again but the outgoing mail does not work. Are there still any possibilities to change it?

more options

It is sounding like the files that contain passwords etc are messed up and something is still pointing to the wrong settings.

You should be using these settings for smtp. Server name: smtp.gmail.com Port: 465 User name: full gmail email address Set Authentication Method : OAuth2 Connection Security: SSL/TLS

Please try the following as it is sounding like something is not properly set up in the prefs.js file, so it is possible the pkcs11.txt is either corrupt or missing.

  • Menu app icon ≡ > Help > More Troubleshooting Information
  • Under 'Application Basics' - Profile Folder - click on 'Open Folder'

This opens a new window showing the contents of your current in use profile name folder.

  • Exit Thunderbird now - this is important.

Look for the following files and delete them.

  • cert8.db - obselete file
  • key3.db - obselete file
  • pkcs11.txt (This should exist but some people find it is missing)
  • secmod.db - obselete file
  • session.json
  • xulstore.json

NOTE: Do NOT delete:

  • key4.db
  • cert9.db
  • logins.json

Once all done, Start Thunderbird. If google prompts - Enter email address and normal password and allow Thunderbird access.

more options

Dear Toad-Hall, I am sorry you are loosing your precious time trying to help me. I am 80 years old and do not belong to the world of today. Perhaps this is the reason why I cannot find in my computer what you suggest, i.e.

   " Menu app icon ≡ > Help > More Troubleshooting Information
   Under 'Application Basics' - Profile Folder - click on 'Open Folder' 

This opens a new window showing the contents of your current in use profile name folder" and so on.

I really appreciate your trying to help me solve my problems but I presume I am not the man to be helped.

All the best to you, witoldrem

more options

Do you use the top 'Menu bar' toolbar ? It says 'File, Edit, View, Go, Message. Events and Tasks, Tools, Help

If yes, click on 'Help' and you will see a drop down list - click on 'More TRoubleshooting Information' See image below.

If you cannot see image as it is too small then in this forum question - click on the icon and it will display much bigger.

Modified by Toad-Hall

more options

re :Under 'Application Basics' - Profile Folder - click on 'Open Folder'

The 'More TRoubleshooting Information' opens in a new tab Please see image below as guide. If you cannot see image as it is too small then in this forum question - click on the icon and it will display much bigger.

more options

After clicking on 'Open Folder' button, it opens in a new window.

  • Exit Thunderbird now - this is important.

Look for the following files and delete them.

  • cert8.db - obselete file
  • key3.db - obselete file
  • pkcs11.txt (This should exist but some people find it is missing)
  • secmod.db - obselete file
  • session.json
  • xulstore.json

NOTE: Do NOT delete:

  • key4.db
  • cert9.db
  • logins.json

Then restart Thunderbird.

more options

The indicted filew have been deleted but outgoing mail does not work. When I open "new mail" then a window with "strange" lines of text is opened. After pressing "send" immediately is information that authentication failed (wrong password). Next information tells to try with new password but no room to introduce the password appeares. Strange for me is also the fact that the removed files pkcs 11, session.json and xulstore.json appeared in the folder after restarting Thunderbird.

more options

re :Strange for me is also the fact that the removed files pkcs 11, session.json and xulstore.json appeared in the folder after restarting Thunderbird.

No. It is normal and expected. If there was any corruption in the files, it would be removed and new files automatically created.


re: When I open "new mail" then a window with "strange" lines of text is opened. Image shows the problem and that is not correct.

Close all Write windows. Close Address Book. This time we are going to have to clear currently stored passwords.

First clear them from the stored passwords.

Using top menu - Tools > Preferences Select 'Privacy and Security'

Scroll to Passwords section Click on 'Saved Passwords' Click on 'REmove all'. OR select each in turn and click on 'REmove' click on 'Close'

Exit Thunderbird - give it time to do background file work.

do not restart until you have checked password.

please check the password. There is only one way to check the password. Try to logon to the gmail webmail account via a browser using email address and password. If you get access then you know the password is correct.

Start Thunderbird, Google will pop up and ask for email address and password to allow Thunderbird access.

Please report back on results.

  1. 1
  2. 2