Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

[Linux] All sessionstore settings except "max tabs undo" are completely ignored on reboot

  • 7 replies
  • 1 has this problem
  • 24 views
  • Last reply by ctrentsj

more options

No matter what I do to firefox to try and prevent it from restoring my session on reboot (which is the behavior I would *least* prefer, I'd prefer if firefox refused to launch at all and required me to manually delete all the session files before I'd want it to restore my session automatically) It """""helpfully""""" brings my window back up with every single tab and window I had open before I *****restarted my computer*****.

All I want is for firefox to open with a fresh session *every single time I open it*. I never want sessionstore to ever work at all in any circumstance whatsoever.

No matter what I do to firefox to try and prevent it from restoring my session on reboot (which is the behavior I would *least* prefer, I'd prefer if firefox refused to launch at all and required me to manually delete all the session files before I'd want it to restore my session automatically) It """""helpfully""""" brings my window back up with every single tab and window I had open before I *****restarted my computer*****. All I want is for firefox to open with a fresh session *every single time I open it*. I never want sessionstore to ever work at all in any circumstance whatsoever.

Modified by ctrentsj

Chosen solution

Terry said

Are you exiting before restarting your computer? You should do that and you should use the exit command (either in the menu or the keyboard shortcut). I suggest you also allow enough time for the process to finish before restarting the computer. Also check that you have NOT selected Settings > General > Startup > Open previous windows and tabs [right at the top of the page].

I ended up replacing all of the files that Firefox uses to store session data with empty files, and then doing a quick "chmod a=r <file>". This works beautifully, but I shouldn't have to do this to get a browser to stop doing something stupid.

Terry here has put forth the official (terrible) solution, which, while functional, is absolutely idiotic and a complete failure on mozilla's part.

Read this answer in context 👍 0

All Replies (7)

more options

Are you exiting before restarting your computer? You should do that and you should use the exit command (either in the menu or the keyboard shortcut). I suggest you also allow enough time for the process to finish before restarting the computer.

Also check that you have NOT selected Settings > General > Startup > Open previous windows and tabs [right at the top of the page].

more options

Terry said

Are you exiting before restarting your computer? You should do that and you should use the exit command (either in the menu or the keyboard shortcut). I suggest you also allow enough time for the process to finish before restarting the computer. Also check that you have NOT selected Settings > General > Startup > Open previous windows and tabs [right at the top of the page].

This is easily the stupidest user experience problem I've ever seen, if this is the only way to get expected behavior to occur. I have never met anyone who individually closes every application they have running before shutting down their computer, and even if someone does, I defy you to show me a single person who does it by opening each application window and locating the exit menu option or using the keyboard shortcut, instead of just pressing the close button on the title bar.

more options

Chosen Solution

Terry said

Are you exiting before restarting your computer? You should do that and you should use the exit command (either in the menu or the keyboard shortcut). I suggest you also allow enough time for the process to finish before restarting the computer. Also check that you have NOT selected Settings > General > Startup > Open previous windows and tabs [right at the top of the page].

I ended up replacing all of the files that Firefox uses to store session data with empty files, and then doing a quick "chmod a=r <file>". This works beautifully, but I shouldn't have to do this to get a browser to stop doing something stupid.

Terry here has put forth the official (terrible) solution, which, while functional, is absolutely idiotic and a complete failure on mozilla's part.

Modified by ctrentsj

more options

It is pretty common sense to completely close a application(s) before you shut down your OS or that applications(s) could crash or have issue next time you start it.

You have been lucky if you have not had noticeable issues till recent.

https://support.mozilla.org/en-US/kb/restore-previous-session https://support.mozilla.org/en-US/kb/how-do-i-restore-my-tabs-last-time

more options

See also this pref on the about:config page.

  • browser.sessionstore.resuming_after_os_restart
more options

cor-el said

See also this pref on the about:config page.
  • browser.sessionstore.resuming_after_os_restart

Is set to false by default and is still set to false. You were saying?

more options

Oh charming. It updated my file permissions too. Mozilla be acting like Microsoft with its forced functionality. It's a bad look, especially for a linux client.