Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird account email setup

  • 15 replies
  • 1 has this problem
  • 19 views
  • Last reply by Matt

more options

Hi,

I installed TB on my laptop but i can't setup any email: i tried gmail, yahoo and ik with the same negative result. I'm on setup page, write email and password (remember password check marked), then google page opens for verification and i allow TB to everything. For Google is ok and i received an email that confirm TB is allowed to see, modify etc but in TB error says: "Unable to log in at server. Probably wrong config, username or password" but if it was wrong i can't be log on Google. About configuration, that is automatic, i have this:

Incoming server Protocol: IMAP Hostname: imap.gmail.com Port: 993 Connection security: SSL/TLS Authentication method: OAuth2 Username: mine Outgoing server Hostname: smtp.gmail.com Port: 465 Connection security: SSL/TLS Authentication method: OAuth2 Username: mine

Same problem with other email account I've try to find a solution by reading support but... Someone can help me?

Hi, I installed TB on my laptop but i can't setup any email: i tried gmail, yahoo and ik with the same negative result. I'm on setup page, write email and password (remember password check marked), then google page opens for verification and i allow TB to everything. For Google is ok and i received an email that confirm TB is allowed to see, modify etc but in TB error says: "Unable to log in at server. Probably wrong config, username or password" but if it was wrong i can't be log on Google. About configuration, that is automatic, i have this: Incoming server Protocol: IMAP Hostname: imap.gmail.com Port: 993 Connection security: SSL/TLS Authentication method: OAuth2 Username: mine Outgoing server Hostname: smtp.gmail.com Port: 465 Connection security: SSL/TLS Authentication method: OAuth2 Username: mine Same problem with other email account I've try to find a solution by reading support but... Someone can help me?

All Replies (15)

more options

Did you remove your password from account? Do that and then connect. That normally does it, leaving the password setting to Google.

Helpful?

more options

Remove password from gmail? I must have a password i can't remove it. I haven't two steps verification or other

Helpful?

more options

Google will prompt for email when you attempt to connect. But remove yours first or TB will attempt to login with the old password and not the Oauth2 password that Google will provide.

Helpful?

more options

This is not about update, it is just first download and utilization so i don't understand why so many problems. On my smartphone i have fairmail and it works well. Also, i can't remove password from google, i can only change it.

Helpful?

more options

The issue isn't TB, it's the authentication requirement by Google. You can remove your password at the preferences>privcy&security section. click 'show password's and then right-click your gmail account settings (there should be two) and remove password.

Helpful?

more options

Notification was in spam, don't know why, so I just read it. Strange, because other clients don't have this issue. Actually can't remove password as you say. Google password can't be removed but only changed. It's one password for all google services and I can't remove it in gmail or in google. Even searching on internet I didn't find something on that.

Helpful?

more options

Here are the basics:

- change your security authorization to Oauth2 (do this for the server settings and also for the Outgoing (SMTP) server - two places - remove the password entries for the account (remove the entire entries both incoming and outgoing) - check to ensure that TB is set to accept cookies - Google will then step you through the authentication process for your PC.

Helpful?

more options

Ok i give up... I think you don't really red my first message... otherwise i try without password and it give the same result. Also I don't have any problems with other email client, so i sure that there is no solution then leave TB. Anyway thank you for your help

Helpful?

more options

You say your gmail Account server settings both incoming and outgoing are using: Username: mine That user name must be your full gmail email address. So if you have not entered full gmail email address, please edit. Confirm user name is your full gmail email address.

Confirm you have cookies enabled:

  • Select 'Menu app icon' > 'Preferences' > 'Privacy & Security '

Under 'Web Content'

  • Select 'Accept cookies from sites'

It may also be a good idea to make exception:

Do you have any programs that clean up files like CCleaner, WiseCleaner or even some Anti-Virus products can do it? If yes, then you need to make Thunderbird profile name folders exempt. You do not want any product accessing and cleaning up files like cookies, session, passwords etc.

Re : Passwords When david was talking about passwords - he was specifically taking about removing what may have been stored in Thunderbird and not talking about modifying the actual password which can only be done via gmail webmail.

So please check the following:

  • Select 'Menu app icon' > 'Preferences' > 'Privacy & Security '

Under 'Passwords' section

  • click on 'Saved Passwords'

For the gmail account - You should have an oauth:// accounts.google.com...for gmail line - this is ok.

BUT do you also see an imap:// line and a smtp:// line for the gmail account ? If you see an imap:// line and a smtp:// line for the gmail account : select imap://imap.gmail.com.... line to highlight and then click on 'Remove' select smtp://smtp.gmail.com.... line to highlight and then click on 'Remove' click on 'Close'


Restart Thunderbird.

Helpful?

more options

I said email is "mine" cause i don't want to enter here my email. If i really write "mine", TB can't even find a configuration server, then can't show me Google window for login.

Yes sure, accept cookies from site is on, I try to make an exception as you suggest but nothing change.

One again is my first TB time so there are no passwords saved (I removed them as you said but nothing change), also i didn't change my email password. I have the same problem with Yahoo account but I'm just talking about Google to start.

I put there some screenshots and I hope this help to understand

Helpful?

more options

re : I said email is "mine" cause i don't want to enter here my email. You do not need to type the email address, just say I entered my 'full gmail email address' would suffice. Some people have a tendency to only enter the first part of email address as username instead of full email address, so that's why we ask if you entered full email address - we are not asking you to actually type your email address in this forum.

re :One again is my first TB time so there are no passwords saved (I removed them as you said but nothing change),

After clicking on the 'Autoriser' button, the mail account was created, so yes passwords were saved. You removed only the lines I said to remove were removed. So that only the oauth: line containing token password was left.

Please Check what is still stored.

  • Select 'Menu app icon' > 'Preferences' > 'Privacy & Security '
  • Under 'Passwords' section
  • click on 'Saved Passwords' button
  • click on 'Show Password' button

You should see one line that looks like this:

Please confirm, do you see this line. I need to know that it exists.


OK looking at images: 1st image: 'Set up your existing email address' - all entries and available configuration look correct. 2nd image: 'Manual configuration' - all looks correct. 3rd image: 'Google Authentication pop up' asking you to authorise Thunderbird access to server - looks correct - the required action is click on 'Autoriser' button - I presume you did click on the 'Autoriser' button.

This would now set up the imap account in Thunderbird. It would save Passwords in the location I previously mentioned. The mail account would appear in the 'Account Settings' window. The mail account would appear in the Folder Pane and also display all the default server folders. You would have to subscribe to see any folders/labels you created.

4th image: Not sure what you are trying to by showing this because that is the window you use to set up a new mail account. Are you trying to add another gmail email address which is completely different from the first one?

You have to understand - if that is the same email address as before then the mail account has already been created and an oauth token has been created. Thunderbird will not allow the same account to be added twice.

Please confirm you can see the gmail mail account/email address in the Folder Pane and it lists all the default folders below the name of the mail account.

Firewall: Your computer will have a Firewall. It might be the default one installed with OS. If you have an Anti-Virus program installed then the Firewall may be controlled by the Anti-Virus.

Exit Thunderbird. Access Firewall. Set up Thunderbird as an allowed program. Thunderbird must be set as an allowed program othewise the Firewall will block access to the internet.

As example - I use Norton 360 Anti-Virus and it controls Firewall. See image below - I have set up Thunderbird and Thunderbird Software Updater as 'Allowed programs.


Please confirm: What Anti-virus are you using? Does the Firewall have Thunderbird set up as an allowed program?

Helpful?

more options

RE: After clicking on the 'Autoriser' button, the mail account was created, so yes passwords were saved. You removed only the lines I said to remove were removed. So that only the oauth: line containing token password was left.

Any account is created and any password is stored. I'm just trying to create few of them but doesn't work.

Re: 4th image

This image it's just what appear on my screen after i click on autoriser button on Google request. Same email and same password. And this is why I'm here asking for help. Firewall and antivirus completely allow TB to work as it was the first request on my laptop when i open TB for the first time. I had check in settings one more if everything is ok and it is. Otherwise, TB can't try to login in google account and show me the pop up window to do that.

I'll show you if i try with IK mail what happens by the following images and you'll see that I set up this email but I can't go further. The account set up page is blocked after "done" and no account appear in the home page. I try to uninstall TB wipe cache, use a cleaner like Glary Utilities 5 and reboot and restart the system. Install TB and have same problems. TB I downloaded from official web site on the last version.

I did't have any problems with outlook on my laptop. On my smartphone I had K9 mail but it didnt't work anymore with Google so i switched to Fairmail and now I don't have problems. Each account on Fairmail works but I don't know how more because update aren't no more on play store or F droid but only on Github. However, Google shows that as Fairmail as TB have authorization on but TB doesn't work.

Helpful?

more options

re :Re: 4th image - This image it's just what appear on my screen after i click on autoriser button on Google request.

Understood. Now that is weird.

Where did you get the download of the Thunderbird program?

Did you get it from here: https://www.thunderbird.net/en-US/thunderbird/all/

At above link you can choose a language and correct Thunderbird for your operating system.

What Operating System are you using? Are you installing everything in the default locations?

Helpful?

more options

From the official web site on the main page: https://www.thunderbird.net/en-US I try even the French but it's the same old story. I Try even msi and 32 bit download in en us fr but no way

I have a MSI laptop where everything works more than properly on Win 10 latest update and TB is located in: C:\Program Files\Mozilla Thunderbird As all other software and games are in C:\Program Files

Helpful?

more options

So the coniguration is found in the ISP database (using port 443) the oauth process occurring on port 443 (the same as for browsing the web) is working, but connecting to the mail server over Port 993 (imap) is not.

The issue is what might be the cause. I harp on about antivirus products and software firewalls a lot. But in this case it is generally the application that they allow or disallow and clearly Thunderbird is allowed as the port 443 stuff is working.

Hardware firewalls however work on ports and protocols, not applications. So check you modem/router is not redirecting or blocking outgoing connections on the port. (generally domestic hardware firewalls only concern themselves with incoming connections. But it is worth checking.

Next are the newest consumer security product. Widely sold and poorly understood. The VPN. Being sold all over the internet, Mozilla even has one. But they don't have a mail client in their stable of products and like many others it does not support mail ports or email. https://support.mozilla.org/bm/questions/1345805

If you have a VPN turn it off.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.