Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot enable anything other than a dark screen

  • 4 replies
  • 1 has this problem
  • 14 views
  • Last reply by russ.jones

more options

For me, running 101.0 on Windows 11, Firefox disregards the selected theme and shows web pages in black no matter what I do (except for these support pages, oddly). Sometimes it renders as black text on a black background, making it impossible to use. My windows theme is "Light", my Firefox theme is "Light". I CAN select ALWAYS to override every web page with a light background and dark text, but obviously that interferes with the design of most web pages. This problem has persisted for months. I have read the suggestions about changing UI settings in about:config and none of them work. As much as I love Firefox and Mozilla, there are many web pages rendered unusable by this problem, and I am about ready to throw in the towel and start using Chrome.

For me, running 101.0 on Windows 11, Firefox disregards the selected theme and shows web pages in black no matter what I do (except for these support pages, oddly). Sometimes it renders as black text on a black background, making it impossible to use. My windows theme is "Light", my Firefox theme is "Light". I CAN select ALWAYS to override every web page with a light background and dark text, but obviously that interferes with the design of most web pages. This problem has persisted for months. I have read the suggestions about changing UI settings in about:config and none of them work. As much as I love Firefox and Mozilla, there are many web pages rendered unusable by this problem, and I am about ready to throw in the towel and start using Chrome.

All Replies (4)

more options

You can check the website appearance setting.

  • Settings -> General -> Language and Appearance -> Website Appearance

Helpful?

more options

None of these suggestions work other than as already stated. I have set both the Windows and the Firefox themes to "light" and Firefox still displays every page as dark.

Helpful?

more options

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior regarding to prefer dark or light background for webpages. You can use 0 (dark) or 1 (light) to set a specific state.

  • about:config => layout.css.prefers-color-scheme.content-override [dark:0, light:1, system:2, browser:3]

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

I have tried that since it's suggested in several other posts, but it doesn't work.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.