Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google?

more options

My Firefox browser is suddenly using Google to search. In Spanish! I don’t know what happened. I want only Firefox

My Firefox browser is suddenly using Google to search. In Spanish! I don’t know what happened. I want only Firefox

All Replies (3)

more options

Type about:preferences#search<enter> in the address box. You can select any search engine to be your default from here.

You can also remove any engine from here.


If you want to add a search engine, check this link: https://mycroftproject.com/

Helpful?

more options

Check your Google settings. Also Firefox Settings > General > Language.

Helpful?

more options

Hi, is this problem in Firefox on your iPhone? Your question ended up under Firefox for desktop (Windows/Mac/Linux) so if a moderator needs to move it to iOS, let us know.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.