Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

[?] instead of text

  • 7 replies
  • 1 has this problem
  • 12 views
  • Last reply by cor-el

more options

Getting [?] instead of text on Goggle search page and gmail. Problem started after I upgraded to Mac OS Monterey. See attached file

Getting [?] instead of text on Goggle search page and gmail. Problem started after I upgraded to Mac OS Monterey. See attached file

All Replies (7)

more options

Here's the screengrab

more options

You get this when Firefox has a problem with accessing the specified font and switches to a last resort font that displays all glyphs as a '?'.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

more options

I followed the directions above, but I am unclear on how to fix the issue. I see in the Inspector the glyph font is Arial.lastResort

more options

screengrab

Modified by matthew55

more options

OK, here's the screengrab

more options

This seems to have fixed the problem:

This bug might be relevant:

Fonts don't display correctly since update due to content-process sandboxing on macOS (#1404919)

Key points:

(A) One workaround is to reduce sandboxing as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and reduce the value from its default value of 3 to 1 and click OK

This reverts the sandbox level in Firefox 56 to what it was in Firefox 52-55 on Mac

That won't take effect until the next time you quit and restart Firefox.

more options

This usually happens if you use a third-party font manager that installs fonts in a location that isn't allowed access due to sandboxing.

See also: