Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Please allow me to limit spell checker options

  • 3 replies
  • 1 has this problem
  • 15 views
  • Last reply by leo-ff

more options

I am tri-lingual, so I switch between three languages all the time. How can I quickly switch between my favorite 3 languages (en_US, de_DE, es_CL)? I couldn't care less about the other locales and only very rarely need other languages like fr_FR. Please get all those out of my way. Please make the drop-down such that it only shows locales I used in the last year, with an extra option "others" where you move all the rest.

I am tri-lingual, so I switch between three languages all the time. How can I quickly switch between my favorite 3 languages (en_US, de_DE, es_CL)? I couldn't care less about the other locales and only very rarely need other languages like fr_FR. Please get all those out of my way. Please make the drop-down such that it only shows locales I used in the last year, with an extra option "others" where you move all the rest.
Attached screenshots

All Replies (3)

more options

You appear to have a lot of dictionaries installed in your Linux distribution. You can possibly remove all unneeded dictionaries and leave only the ones you use.

You can check these locations for globally installed dictionaries:

/usr/share/hunspell/
/usr/share/myspell/

See also the DICPATH environment variable. Some of these dictionaries can have a underscore (en_US) instead of a dash (en-US) in the language selector.

more options

Are you using a package build of Firefox from your Linux distro or such? They tend to also install packages for disctionaries and language packs for Firefox in the package manager you use.

Normally the official builds of desktop Firefox (for Windows, macOS, and Linux) from www.mozilla.org/firefox/all/ only comes with one dictionary or no dictionary depending on the locale due to license reasons. In this case you can install dictionaries from https://addons.mozilla.org/firefox/language-tools/

more options

Thank you @cor-el. `sudo apt remove hunspell-{ar,be,bg,bs,ca,da,de-at,de-ch,el,eu,fr-classical,gl,gu,hi,hr,hu,id,is,kk,kmr,ko,lt,lv,ml,ne,nl,pl,pt*,ro,ru,si,sl,sr,sv,sv-se,te,th,vi,cs} myspell-{eo,et,fa,ga,he,nb,nn,sk,sq} aspell-{a*,b*,c*,da,el,eo,et,eu,fa,g*,h*,i*,k*,l*,m*,n*,p*,r*,s*,t*}` did improve the situation and I get you don't see this as something that should be fixed in FF but I still see a full screen height of mostly spanish locales that I guess are part of some all-locale spanish package.

Regardless of me maybe getting this acceptable this way, I do believe it should be on firefox to facilitate the switching between dictionaries.