Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In LinuxMint 20.3 FF does not open in desktop which called it.

  • 3 replies
  • 0 have this problem
  • 6 views
  • Last reply by johnb0647

more options

When I click on the Firefox icon the app opens in which ever desktop it opened in last, not in the one the user (me that is) is currently in. Annoying but not critical.

This problem appeared after I upgraded to LM 20.3 and the latest FF in Flatpak so I have no idea if the problem is LM or FF or both.

Linux Mint 20.3 Cinnamon Firefox "Mozilla Firefox Flatpak - 1.0 98.0.1 (64 bit)

When I click on the Firefox icon the app opens in which ever desktop it opened in last, not in the one the user (me that is) is currently in. Annoying but not critical. This problem appeared after I upgraded to LM 20.3 and the latest FF in Flatpak so I have no idea if the problem is LM or FF or both. Linux Mint 20.3 Cinnamon Firefox "Mozilla Firefox Flatpak - 1.0 98.0.1 (64 bit)

All Replies (3)

more options

I would say that it's not a browser issue, but more a desktop environment issue. I sometime have that issue with Chrome and Firefox in KDE. Just now it took 3 tries before both browsers opened on the desktop from which I called them. That's my opinion. ;-)

Operating System: openSUSE Tumbleweed 20220321 KDE Plasma Version: 5.24.3 KDE Frameworks Version: 5.92.0 Qt Version: 5.15.2 Kernel Version: 5.16.15-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics 4600

more options

Test a copy of Firefox from Mozilla, run it from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Also, test other browsers, I bet you have the same issue.

Modified by jonzn4SUSE

more options

I tested with the "Brave" browser and it worked properly.

To my surprise, when I tested with TOR browser (which is a fork of firefox) it also worked properly.

I'll give it a try with a new firefox tomorrow.