Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Disable Immersive mode

  • 2 replies
  • 1 has this problem
  • 2457 views
  • Last reply by Sara

more options

The latest Android+Firefox update has Firefox opening in Immersive Mode (full screen, hiding Navigation bar and Status/notification bar). I am frequently navigating between apps, so this requires me to do a lot of extra gestures in my daily interactions with Firefox. Also, I miss being able to quickly check the time and my battery life in the status bar. I know some people like immersive mode, but there are many use cases where forced full screen is not desirable, so there should be a setting to toggle this off.

The latest Android+Firefox update has Firefox opening in Immersive Mode (full screen, hiding Navigation bar and Status/notification bar). I am frequently navigating between apps, so this requires me to do a lot of extra gestures in my daily interactions with Firefox. Also, I miss being able to quickly check the time and my battery life in the status bar. I know some people like immersive mode, but there are many use cases where forced full screen is not desirable, so there should be a setting to toggle this off.

Chosen solution

Seburo said

If you open the Firefox for Android menu, select Settings and Customise, you should see the option to Scroll to hide toolbar. If you turn this off, the toolbar should remain visible.

Thank you, but this setting is for the Firefox toolbar, not the Android navigation bar. I already turned this setting off, and that was working as expected.

After creating this question, I contacted Samsung support as well (device is a Samsung Galaxy S10), and with their help, I think I resolved the issue. I reset the device app settings, and now Firefox is no longer launching in full screen/immersive mode.

Read this answer in context 👍 0

All Replies (2)

more options

Hi

I should be able to help with this. If you open the Firefox for Android menu, select Settings and Customise, you should see the option to Scroll to hide toolbar. If you turn this off, the toolbar should remain visible.

I hope that this helps.

more options

Chosen Solution

Seburo said

If you open the Firefox for Android menu, select Settings and Customise, you should see the option to Scroll to hide toolbar. If you turn this off, the toolbar should remain visible.

Thank you, but this setting is for the Firefox toolbar, not the Android navigation bar. I already turned this setting off, and that was working as expected.

After creating this question, I contacted Samsung support as well (device is a Samsung Galaxy S10), and with their help, I think I resolved the issue. I reset the device app settings, and now Firefox is no longer launching in full screen/immersive mode.