Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox has stopped working

  • 7 replies
  • 1 has this problem
  • 13 views
  • Last reply by James

more options

yesterday firefox worked fine. Today when I opened it, it was slow loading my homepage (my email account) and would open new windows but never open anything in them. It would open new windows from links in an email. It would give no error messages and there was no spinning circle or anything else to indicate that it was working. When I typed in an address and entered, nothing happened. I tried the refresh, but that window wouldn't open. I did a reinstall and now my home page won't even come up. I have an Alienware x17 R1 running Windows 10. Other browsers (Microsoft Edge, Opera) run fine.

yesterday firefox worked fine. Today when I opened it, it was slow loading my homepage (my email account) and would open new windows but never open anything in them. It would open new windows from links in an email. It would give no error messages and there was no spinning circle or anything else to indicate that it was working. When I typed in an address and entered, nothing happened. I tried the refresh, but that window wouldn't open. I did a reinstall and now my home page won't even come up. I have an Alienware x17 R1 running Windows 10. Other browsers (Microsoft Edge, Opera) run fine.

All Replies (7)

more options

Does this help?

jscher2000 said

Could this be relevant? A couple of other users identified Webroot (security software) as blocking 64-bit Firefox 97 -- released today -- from running properly: If you are still running an earlier release of Firefox, this would not be your issue.
more options

I'll paste some of that info here:

If you have Windows 10 or 11, and Webroot security software, and 64-bit Firefox 97, there is an incompatibility which cripples Firefox.

People are working with Webroot to issue an update.

Until then, a user posted that one workaround is to run Firefox 97 in backwards compatibility mode. I haven't tested this myself, but here is how you would set that up:

(1) Open the Properties dialog for your Firefox shortcut. Either:

  • right-click a Desktop shortcut, then click Properties
  • right-click a pinned Taskbar icon, then right-click the Firefox (or Mozilla Firefox) item, then click Properties

(2) Switch to the Compatibility tab

(3) Check the box for "Run this program in compatibility mode for"

(4) If the selector for that option is not set on Windows 8, switch it to Windows 8

As a result of this change, you may notice that some Windows 10-specific features and styling are disabled. However, I am not aware of any major changes. If you experiment with this, let us know your experience.

more options

didn't work for me

more options

Do you use Webroot security software?

more options

yes, I use webroot

more options

jscher2000 said

Could this be relevant? A couple of other users identified Webroot (security software) as blocking 64-bit Firefox 97 -- released today -- from running properly: If you are still running an earlier release of Firefox, this would not be your issue.
more options

https://www.mozilla.org/firefox/97.0.1/releasenotes/

Fixed Works around problems with WebRoot SecureAnywhere antivirus rendering Firefox unusable in some situations