Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

500 MB of RAM per tab??

  • 5 replies
  • 1 has this problem
  • 88 views
  • Last reply by FredMcD

more options

Hi everyone,

I have the problem in the Subject line. FF sucks about 500 MB to be run, on top of which it takes 500 MB per tab, and that makes it impossible to run a research on my 8 GB Mac. Yesterday I was looking for a lamp and had no more than 7 tabs open, 3 of which were largely text, 2 were online shops, and 1-2 were websites with pictures. No Facebook or social media, no YouTube. FF froze, made the whole Mac freeze (well, Mac is garbage nowadays but let's leave that out of this topic), and I had to wait MINUTES before I could close it, because the computer was nonreactive.

When I check online, I see people being like "why can't it manage more than 50 tabs?". 50?!?! My computer dies with a maximum of 10 when it's only text websites!

So, I guess there's something wrong with this.

- I don't have many extensions (SimilarWeb, VPN, and Flash Player), I always use incognito so I can't use the plugin that allows me to use several accounts at the same time, so I can't see what's messing with my Mac. - The Activity Monitor (pretty much Task Manager on Windows) shows "FirefoxCP Isolated Web Content" for each tab, could that have anything to do with my problem? - CPU usage is very low, some 0.5 to 10% max during heavy use. - I seem to remember I used to have dozens of tabs open in the past, although I can't be sure. Is this a recent problem?

I really hope there's a way to solve this, because now I always fear that opening FF while on a Zoom meeting might freeze the whole thing.

Thanks to anyone who might want to shed some light on this big problem.

Screenshots: RAM and CPU usage with 2 tabs open. Two, taking more than 1 GB of RAM and about 250 threads in total? While using 0.2% of the CPU? I'm lost

Hi everyone, I have the problem in the Subject line. FF sucks about 500 MB to be run, on top of which it takes 500 MB per tab, and that makes it impossible to run a research on my 8 GB Mac. Yesterday I was looking for a lamp and had no more than 7 tabs open, 3 of which were largely text, 2 were online shops, and 1-2 were websites with pictures. No Facebook or social media, no YouTube. FF froze, made the whole Mac freeze (well, Mac is garbage nowadays but let's leave that out of this topic), and I had to wait MINUTES before I could close it, because the computer was nonreactive. When I check online, I see people being like "why can't it manage more than 50 tabs?". 50?!?! My computer dies with a maximum of 10 when it's only text websites! So, I guess there's something wrong with this. - I don't have many extensions (SimilarWeb, VPN, and Flash Player), I always use incognito so I can't use the plugin that allows me to use several accounts at the same time, so I can't see what's messing with my Mac. - The Activity Monitor (pretty much Task Manager on Windows) shows "FirefoxCP Isolated Web Content" for each tab, could that have anything to do with my problem? - CPU usage is very low, some 0.5 to 10% max during heavy use. - I seem to remember I used to have dozens of tabs open in the past, although I can't be sure. Is this a recent problem? I really hope there's a way to solve this, because now I always fear that opening FF while on a Zoom meeting might freeze the whole thing. Thanks to anyone who might want to shed some light on this big problem. Screenshots: RAM and CPU usage with 2 tabs open. Two, taking more than 1 GB of RAM and about 250 threads in total? While using 0.2% of the CPU? I'm lost
Attached screenshots

Chosen solution

muvuth said

I've also tried Troubleshooting Mode today for the first time. So far so good. Just to confirm, do I always have to start FF regularly and then basically restart it with the procedure?

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes), any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address box to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Read this answer in context 👍 0

All Replies (5)

more options

muvuth said

I don't have many extensions (SimilarWeb, VPN, and Flash Player)

The Flash Player is end of life. Unless it is still useful to you, it should be removed.


Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

Helpful?

more options

If you notice you have more content processes than in the past then you may have Fission enabled. Fission is about a new site isolation architecture in Firefox and you will see more Firefox processes running than before and when Fission is enabled you can no longer limit the number of content processes in Settings or via dom.ipc.processCount on the about:config page. You can check the current Fission state on the "Help -> More Troubleshooting Information" (about:support) page (search for Fission).

You can for now disable Fission by setting fission.autostart = false on the about:config page. You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

Thanks for your tips, FredMcD.

Fred

FredMcD said

The Flash Player is end of life. Unless it is still useful to you, it should be removed.

Right, will do.

I've also tried Troubleshooting Mode today for the first time. So far so good. Just to confirm, do I always have to start FF regularly and then basically restart it with the procedure?

I checked the posts you sent right before posting my question, and none of them solved it. That's what frustrated me.

I'll lay hopes in the Troubleshooting Mode, thanks!

Helpful?

more options

cor-el said

If you notice you have more content processes than in the past then you may have Fission enabled.

I read this very article while researching my problem before posting, so I'm guessing there is a connection indeed. I like the added security, but I always close FF (cookies and history wiped out) before AND after visiting my online banking sites, so maybe I'll be safe without?

I'll give that a try as well, thank you.

Helpful?

more options

Chosen Solution

muvuth said

I've also tried Troubleshooting Mode today for the first time. So far so good. Just to confirm, do I always have to start FF regularly and then basically restart it with the procedure?

https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes), any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address box to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.