Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird receiving repeat emails from gmail account plus normal password vs oauth

  • 4 replies
  • 1 has this problem
  • 5 views
  • Last reply by djholter

more options

I had been getting the username and password unrecognized from my gmail account. So I switched from normal password to oauth but now I am getting 300-400 emails every time I log on and they're all emails I received in 2014 and 2015. Thunderbird never downloads the new mail I have waiting in my gmail account (I use pop).

I'd prefer to go back to normal password to stop getting all these repeat emails from years past but np will not work. How do I stop the old emails and start getting the new ones waiting to be downloaded?

I know these have been brought up from other users but individually. I'm not seeing issues when transferring from np to oauth like I'm experiencing. Thanks for any help.

Chosen solution

I said to change the setting at google for POP. Apparently you have not done that.

Go to this link https://mail.google.com/mail/u/0/#settings/fwdandpop and look at the very first thing in the POP part.

In my case it says "Status: POP is enabled for all mail that has arrived since 7/11/10" under that you can set it to "Enable POP for mail that arrives from now on" That will stop the old stuff dead.

Read this answer in context 👍 0

All Replies (4)

more options

There is zero difference in oAuth and normal password for this. Except Google is working to completely refuse connections using anything but oAuth in the future. The problem and password change are unrelated. Even if they happened within seconds of one another. (unless you added the account again, and that would be difficult without removing it first, and that would be silly)

Gmail generally provides you an option to limit pop downloads for a date, and turning pop off and on again should set that date to "today" But repeated downloads of old mail are usually caused by a damaged or corrupt popstate.dat file. Damage to this file is sometime caused by anti virus programs trying to scan it when Thunderbird is trying to use it. Without it's information on where the downloads for the account are up to, you get reset to the beginning and everything offered by the server is downloaded.

Repeatedly closing the application while the download is continuing will probably only result in yet more copies and the file is updated at the completion of the download of mail for the session. So if you cut it off after a couple of hundred messages you will probably see them again the next time you start up as Thunderbird has not updated the session information from the last connection. Force quiting the application from the task manager is even more unlikely to have a satisfactory result.

Helpful?

more options

Matt thanks so much for writing out the information about this issue. I will accept oAuth if I have to.

I turned off Pop and restarted TB, turned it on and restarted again but that didn't do anything.

I deleted the popstate.dat file and TB did regenerate a new one. But that didn't seem to help, even though I've patiently sat through the downloading of old messages as suggested, new messages are still not being released from Gmail.

I looked for a way to limit pop downloads in Gmail but didn't find one. There was a suggestion to put "recent:<emailaddresss>" as the inbound server setting in TB but that didn't work either.

I appreciate the suggestions but if anything else comes to mind, please let me know.

Thanks so much!

Helpful?

more options

Chosen Solution

I said to change the setting at google for POP. Apparently you have not done that.

Go to this link https://mail.google.com/mail/u/0/#settings/fwdandpop and look at the very first thing in the POP part.

In my case it says "Status: POP is enabled for all mail that has arrived since 7/11/10" under that you can set it to "Enable POP for mail that arrives from now on" That will stop the old stuff dead.

Helpful?

more options

Thank you Matt, it did the trick. One thing to note, once you select the "Enable POP for mail that arrives from now on" option, it literally sets that specific time and will not download any emails that are in your Gmail account from the time the problem started. FWD'ing the emails to myself is my work around. I also put the popstate.dat file in the Windows Security Exclusions option as a file to allow and not mess with in hopes to avoid corruption in the future.

Perhaps Thunderbird could offer an option to go in and set the date/time to allow downloads manually. A "Enable POP for mail that arrives from <insert date> onward" or something like that.

Again, thanks Matt, you really helped me with this bizarre issue! Regards, djholter

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.