Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Link do not load on page after Firefox upgrade

  • 7 replies
  • 1 has this problem
  • 7 views
  • Last reply by FredMcD

more options

I frequently use the site SAM.gov to look at US government solicitations where documents are posted for the public to download. Recently the links to those documents fail to load on Firefox when it did just a couple of weeks or less ago. I am now forced to use MS browser just to see those.

For example go to https://sam.gov/opp/81551b02dd2d4e2b8fc06ce327d57113/view look for "Attachments" about 2/3 of the way down and you can see the circling caterpillar thingie where the links should be.

is there a setting or fix? Thank you in advance

Modified by Matt

Chosen solution

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Read this answer in context 👍 0

All Replies (7)

more options

Your query has landed in the Thunderbird support forum. I will transfer is to the Firefox one as I am really no well versed in Firefox support.

I can tell you that I clicked the link, scrolled down and the attachments showed a list of files and clicking the links to them raised an offer to download them. See below.

Helpful?

more options

I'm sorry about the wrong forum and thanks for correcting it. Can you take a guess the reason is for me not seeing the links?

I've tried the only thing I can think of: Ctrl-F5

Helpful?

more options

I did have a quick look as the page, and the whole thing is scripted. It is possible that your anti virus might be blocking it as a third part thing, or even some of your more "paranoid" Firefox settings, or an addon.

I would suggest you go to the troubleshooting information on the help menu and use the clear cache and troubleshooting mode buttons in that order if the cache is the issue then don't continue obviously.

Next I suggest you try the refresh option, if neither of those other two do anything. But I also counsel you to read about the refresh so you know what it really means. See https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Helpful?

more options

Chosen Solution

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Helpful?

more options

Thank you all. A clearing of all cookies solved the problem. Since that had never happened in >10 years of usage I did not try it until it was mentioned.

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.