Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New 91.0 v has messed up all of websites I frequent

more options

Just downloaded 91.0 and the next time I started up Firefox all of the websites that I frequent...just about all of their design (fonts, colors, etc.) are GONE! What the heck? It's like all of their formatting is no longer recognized. I don't have time to figure out how to get it all back. Clickable links use to turn color; can't put check marks in boxes when doing surveys (I was doing a survey when I chose to just download the update, and I was able to check boxes at that time; now I can't even check the box below to indicate I want to be emailed when someone answers this question! ... @verizon.net, by the way, if you want to email me to know you've answered this question.) I have never experienced this in the past. Is there an easy answer to this? Anyone else experience this? I am on iMac Mojave 10.14.6.


edited email from public and search/spam bots view as this is a public community forum.

Just downloaded 91.0 and the next time I started up Firefox all of the websites that I frequent...just about all of their design (fonts, colors, etc.) are GONE! What the heck? It's like all of their formatting is no longer recognized. I don't have time to figure out how to get it all back. Clickable links use to turn color; can't put check marks in boxes when doing surveys (I was doing a survey when I chose to just download the update, and I was able to check boxes at that time; now I can't even check the box below to indicate I want to be emailed when someone answers this question! ... @verizon.net, by the way, if you want to email me to know you've answered this question.) I have never experienced this in the past. Is there an easy answer to this? Anyone else experience this? I am on iMac Mojave 10.14.6. edited email from public and search/spam bots view as this is a public community forum.

Modified by James

Chosen solution

I turned off the High Contrast Mode and thought "why should everything else suffer just because Firefox messed with this?" Then I did your second suggestion with High Contrast Mode on and everything seems to be back to normal. Even reading the new release notes, I would have never figured that one out. I am from a beginner being a graphic designer and on computer since mid 90s. It is frustrating when things like this are not revealed up front. Perhaps there could have been some explanation like "if you want web pages to look like they should, do one of two things: turn High Contrast Mode off or opt to choose 'Never' for 'Override colors...'" Using words...the key to good communication. Thanks so much, cor-el, for answering my gripe!!

Read this answer in context 👍 0

All Replies (4)

more options

I am adding an example. The image with USAA in full color is Safari. The one with white background is Firefox. The Safari image is how the site should look when I pull it up in Firefox. There are other issues...like all type is contained in a white box, even if there is a color background. Firefox is doing that within Facebook (image attached...those names use to be embedded within photos, not in white boxes). I want my old Firefox back!

more options

Until someone can answer this question or Firefox fixes the interface back to how I was able to view websites, I have set Safari as my default browser. Really dislike doing this as I love(d) Firefox. This may be farewell to Firefox. Really wish I could figure out how to get my answers without having to do it in a community blog.

more options

This could be a problem with High Contrast Mode on Mac.

See "New" in the release notes.

Firefox now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS in the Accessibility settings.


Make sure you allow pages to choose their own colors.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

more options

Chosen Solution

I turned off the High Contrast Mode and thought "why should everything else suffer just because Firefox messed with this?" Then I did your second suggestion with High Contrast Mode on and everything seems to be back to normal. Even reading the new release notes, I would have never figured that one out. I am from a beginner being a graphic designer and on computer since mid 90s. It is frustrating when things like this are not revealed up front. Perhaps there could have been some explanation like "if you want web pages to look like they should, do one of two things: turn High Contrast Mode off or opt to choose 'Never' for 'Override colors...'" Using words...the key to good communication. Thanks so much, cor-el, for answering my gripe!!