Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Am having font rendering issues.

more options

Is anyone encountering rendering issues when viewing websites? I'm getting all sorts of artifacts with certain fonts.

Attached screenshots

All Replies (4)

more options

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

Helpful?

more options

This seems to be a pretty severe case. Is there a public page on that site which exhibits the same problem that you can link to?

Note: put a space in the address before the .com (or whatever top level domain) to break the link so your reply isn't delayed in moderation.

Helpful?

more options

It is possible that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

more options

This started happening after upgrading to Big Sur and the latest version of Firefox. It doesn't happen all the time, but often.

The font handling sets are all on default. Nothing has changed.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.