Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't pin "Nightly" to Ubuntu taskbar. Can only load from "MOZ" command! Help!

  • 9 replies
  • 1 has this problem
  • Last reply by Seburo

more options

My install of Firefox was somehow corrupted. I was instructed by FF tech support to download the latest "Nightly" build, extract it to my "Downloads" folder, and launch it using the following command:

MOZ_ACCELERATED=0 MOZ_WEBRENDER=0 ~/Downloads/firefox/firefox

This opens a working install of "Nightly" (with purple & blue firefox icon), but as soon as I close it, the icon goes away. The program is not recognized as "installed" so it does not appear in a search for installed apps. And if I right-click on its icon while running, "Pin to taskbar" is not an option.

"Nighly" is working (I'm using it to type this) and I even have it Synced to my account, but the ONLY way to launch it is via the Terminal CLI. :(

My broken copy of "Firefox" is still listed as installed, but is unusable.


All Replies (9)

more options


Have you set a .shortcut file for the copy that you have installed?

What desktop environment are you using?

more options

It's not "installed" (as far as Ubuntu is concerned.) There's nothing to form a shortcut to.

The program only runs if launched from the Terminal using the aforementioned command line.

I attempted to simply paste the command to a text file saved to the desktop, set "Open with" to Terminal and set the file to "Run as program", but that does absolutely nothing. :(

I'm using the default Ubuntu desktop.

Modified by Mugsy

more options

I'm in KDE and have Nightly pinned. see screenshots

Modified by jonzn4SUSE

more options

Thx for the reply, but I've tried KDE and had too many problems with it. :(

Is there a way to fully "install" the "Nightly" build? No "installer"/setup utility is included with the download.

more options

Mugsy said

My install of Firefox was somehow corrupted. I was instructed by FF tech support to download the latest "Nightly" build,

You should use the current Release from or Beta channel builds (a version can get get say 9 to 14+ builds on beta channel) at most but if you want to continue using the unstable Nightly channel builds.

The tarbal are basically just extract and run the firefox .sh and use Firefox. There is no installer or setup for the Linux tar builds from Mozilla. You have to manually create a desktop or panel or menu launcher to the firefox .sh in the Firefox folder. You can find a Firefox icon to use in the Firefox folder firefox/browser/chrome/icons/default

Also if you want updates for the Fx Linux builds from Mozilla you need to make sure the Firefox folder has user read/write permissions as many often put the Firefox folder in Home to make it easy if you are the only user.

Mozilla does not have any one on one support by phone, chat or email if that is what you mean by instructed by Fx tech support.

Not sure what Fx tech support you are referring to but nobody should tell an average Firefox user to use the unstable Nightly development channel builds that can get checkins and updates twice a day. The Nightly channel are more for developers and testers in mind.

more options

Sorry for the late reply (Linux is not my everyday OS.)

I downloaded the latest release (90.0) from your link, but I'm not finding a ".sh" shell file anywhere in the archive. I had previously downloaded v91.0 from the archives, but it didn't resolve my issue.

That is when I was directed by Firefox (Developer?) Support via GitHub to try the "Nightly" build, which runs/works, but only when run using the aforementioned command from the terminal.

The Ubuntu Updater used to include FF updates, but no longer. I can still find and launch FF from the "Activities" screen, but as noted originally, what launches is unusable with no apparent cause or fix.

It makes no sense to me that both "Chromium" & "Nightly" display just fine, but the only thing FF displays is a washed out (to the point of pure white) box with no visible controls. All attempts to reinstall it have failed b/c the Linux release does not include a Setup utility (the closest being "flatpak", which also didn't resolve the issue.)

Is there a way to perform a clean reinstall of FF?

PS: I tried launching FF in it's "safe mode" but it made no difference. Note the faded colors visible in the screenshot only became visible when the screenshot was taken. TIA

UPDATE: I just discovered something odd: If I launch "Nightly" using the noted MOZ Terminal command, it displays fine, but if I try to "Run" Firefox directly from the same location ("~/Downloads/firefox/firefox"), I get the same washed out window. What is different about launching "Nightly" using the following command that "fixes" the problem? (MOZ_ACCELERATED=0 MOZ_WEBRENDER=0 ~/Downloads/firefox/firefox)

Modified by Mugsy

more options

Unless you specifically wish to use Nightly, have you tried the Snap version available in GNOME software in Ubuntu?

more options

Thx for the reply.

Is this in the Ubuntu "Software Store" (satchel icon)? Because it does not list "Firefox".

Do I search for "Snap"? Is there a specific download link?

more options

Yes, the Ubuntu Software Store.

Search for "Mozilla Firefox web browser". Under "details", it should list the "source" as being