Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to edit shortcuts

  • 12 replies
  • 1 has this problem
  • 89 views
  • Last reply by cor-el

more options

I can't find an option to customize shortcuts - where is it? Don't tell me this browser does not have such an option - all other, including Chrome and Opera do.

All Replies (12)

more options

Open the Bookmarks Manager; Press the Alt or F10 key to bring up the toolbar, and select Bookmarks. Hot key is <Control> (Mac=<Command>) <Shift> B. Firefox 84+ <Control> (Mac=<Command>) <Shift> O.

Click on the entry you want to change. You can edit the information at the bottom of the window.

Helpful?

more options

Helpful?

more options

FredMcD said

Open the Bookmarks Manager; Press the Alt or F10 key to bring up the toolbar, and select Bookmarks. Hot key is <Control> (Mac=<Command>) <Shift> B. Firefox 84+ <Control> (Mac=<Command>) <Shift> O. Click on the entry you want to change. You can edit the information at the bottom of the window.

Thank you for the reply, I've opened bookmarks manager and see an empty page (since I have no bookmarks presumably). Can you, please, explain how looking at my empty bookmarks can change browser shortcuts(hotkeys)?

By shortcuts(hotkeys) I mean key combinations that are used to speed up working with the browser. For example, in Opera I can set Ctrl+Q combination to open bookmarks sidebar, because this is a comfortable key to use. But in Firefox nor can I find a standard hotkey for opening sidebar, neither I can find any configuration for customizing key combinations.

Helpful?

more options

Sorry. I called for more help.

Helpful?

more options

I have posted a reply over an hour ago that still hasn't been cleared by a moderator.

In that post I provided a link to an extension :

https://addons.mozilla.org/en-US/firefox/addon/shortkeys/

as well as a link to a ghacks page.

Helpful?

more options

Rodney said

I have posted a reply over an hour ago that still hasn't been cleared by a moderator.

Here's the cleared post:

https://addons.mozilla.org/en-US/firefox/addon/shortkeys/ Also see: https://www.ghacks.net/2019/12/31/add-custom-shortcuts-to-your-web-browser-with-shortkeys/

Helpful?

more options

Sorry, current forum security sometimes delays the posting of messages. And in turn, we are not notified of those posts.

Helpful?

more options

Rodney said

Rodney said

I have posted a reply over an hour ago that still hasn't been cleared by a moderator.

Here's the cleared post:

https://addons.mozilla.org/en-US/firefox/addon/shortkeys/ Also see: https://www.ghacks.net/2019/12/31/add-custom-shortcuts-to-your-web-browser-with-shortkeys/

Thank you for the links. It was rather tricky to find out how to configure that addon, but looks like it can not do anything what I need:

1. There is no option to set up a hotkey for opening a bookmarks sidebar 2. There is no option to disable default hotkey for ctrl+Q which quits the browser

So looks like Firefox does not support customization from the box and addon functionality is very limited. Are there any other options?

Helpful?

more options

Th3End said

1. There is no option to set up a hotkey for opening a bookmarks sidebar

Ctrl + B opens a bookmarks sidebar.

2. There is no option to disable default hotkey for ctrl+Q which quits the browser

See: https://askubuntu.com/questions/10880/disable-ctrlq-in-firefox-without-keyconfig-extension



Maybe you'll find this useful: https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly

Helpful?

more options

You can use an autoconfig.cfg file to disable the #key_quitApplication command and possibly others.

See this sub Reddit for an example.


I use code like this in autoconfig.cfg to disable "Ctrl+Q" and some others (Ctrl+R).

// first line is a comment line
try {
 let {classes:Cc, interfaces:Ci, manager:Cm, utils:Cu} = Components;
 const {Services} = Cu.import('resource://gre/modules/Services.jsm');
 function ConfigJS() { Services.obs.addObserver(this, 'chrome-document-global-created', false); }
 ConfigJS.prototype = {
  observe: function (aSubject) { aSubject.addEventListener('DOMContentLoaded', this, {once: true}); },
  handleEvent: function (aEvent) {
   let document = aEvent.originalTarget;
   let window = document.defaultView;
   let location = window.location;
   if (/^(chrome:(?!\/\/(global\/content\/commonDialog|browser\/content\/webext-panels)\.x?html)|about:(?!blank))/i.test(location.href)) {
    if (window._gBrowser) {
     let attr, elm, key, mbo;
      let KEYS = ['key_quitApplication','key_reload'];
      let ATTR = ['key','modifiers','command','oncommand'];
      for (key in KEYS){
       elm = window.document.getElementById(KEYS[key]);
       if (elm) for (attr in ATTR) if (ATTR[attr] in elm.attributes) elm.removeAttribute(ATTR[attr]);
      }
    }
   }
  }
 };
 if (!Services.appinfo.inSafeMode) { new ConfigJS(); }
} catch(e) {Cu.reportError(e);}


Helpful?

more options

Rodney said

Ctrl + B opens a bookmarks sidebar.
See: https://askubuntu.com/questions/10880/disable-ctrlq-in-firefox-without-keyconfig-extension Maybe you'll find this useful: https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly


Thank you for the links, surely knowing the default key for sidebar and how to disable ctrl+Q is a useful information, still does not help me to assign ctrl+Q for opening sidebar. "B" is too far away from "Ctrl" - I don't want to break my arms trying to use that combination hundreds times a day.

cor-el said

You can use an autoconfig.cfg file to disable the #key_quitApplication command and possibly others. https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig See this sub Reddit for an example. https://www.reddit.com/r/firefox/comments/kilmm2/restore_ctrlshiftb_library_by_setting_configjs/


Oh these are the links of a great value, so looks like my concerns were right and firefox is not customizable and that will never be fixed. (21 year old opened bug report lel) At least there is an option to execute user supplied code in the browser. I will look into it and try to figure out if there is a way to do what I want. Thank you!

Helpful?

more options

Firefox 87+ versions have a pref to disable Ctrl+Q.

  • browser.quitShortcut.disabled = true

You need to close and restart Firefox after toggling this pref.


  • 1325692#c56 - [commands] Explicit support for overriding built-in keyboard shortcuts by WebExtensions

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.