Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarks Dropdown Now has "Other Bookmarks" and 2x (twice) "Manage Bookmarks"! Help.

  • 2 replies
  • 1 has this problem
  • 5 views
  • Last reply by William K.

more options

Good day,

It would appear that there was an update in the past 24hrs because my tabs appear different (rounder). However, now my bookmarks drop-down menu is all different and messed-up, and I can't delete the things added. Please see the screenshot enclosed...

I now have "Manage Bookmarks" at the top - which is fine. I have "Other Bookmarks" - which I thought I killed a LONG time ago. I have an ADDITIONAL "Manage Bookmarks" at the bottom - which seems redundant, and excessive.

I've done my homework, tried tinkering with old solutions. I cannot delete, move, rename, hide or change any of these. I would ideally like to remove everything except the 1st "Manage Bookmarks" at the top. That seems reasonable.

Thanks for your time and help! William (FF89)

Good day, It would appear that there was an update in the past 24hrs because my tabs appear different (rounder). However, now my bookmarks drop-down menu is all different and messed-up, and I can't delete the things added. Please see the screenshot enclosed... I now have "Manage Bookmarks" at the top - which is fine. I have "Other Bookmarks" - which I thought I killed a LONG time ago. I have an ADDITIONAL "Manage Bookmarks" at the bottom - which seems redundant, and excessive. I've done my homework, tried tinkering with old solutions. I cannot delete, move, rename, hide or change any of these. I would ideally like to remove everything except the 1st "Manage Bookmarks" at the top. That seems reasonable. Thanks for your time and help! William (FF89)
Attached screenshots

All Replies (2)

more options

WARNING: This script is not provided by Mozilla and is not officially supported Creating a userChrome.css file and other ways of customizing Firefox that are not exposed in the interface are there for developers, not end-users. If it were intended for end-users, you would see a menu option or checkbox; you wouldn't have to hack a text file in a hidden location.

What this means is that even though the functionality you want is no longer supported, a third-party has found a way to do it using the CSS file. If it breaks in new versions, you will need to contact the person who provided the script.

[Warning added by moderator]


You can add code to the userChrome.css file below the default @namespace line to hide some items. See also the Browser Toolbox to get selectors for items to hide.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* Hide Other Bookmarks  */
#BMB_unsortedBookmarks { display:none!important; }

/* Hide Manage Bookmarks at the bottom */
#BMB_bookmarksShowAll { display:none!important; }

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

See also:

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

  • toolkit.legacyUserProfileCustomizations.stylesheets = true

Modified by Chris Ilias

more options

I really appreciate the effort and time you took to lay that all out for me. Must admit, my head is swimming a bit. If there is no easier solution to fix such a ridiculous oversight I will have to take the time to learn .css stuff...

There must be an easier solution - it's ridiculous! Yesterday everything was fine, and today Mozilla hoses the entire interface. It makes me want to rage-quit FF.

Again, thanks... Any other suggestions? :)