Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

CentOS Stream and RHEL Flatpak Firefox 88: Facebook videos play at more or less 15fps, but audio is fine

more options

While youtube videos is flawless, facebook videos seem to play at 15fps. Audio plays flawlessly though.. It happens with both CentOS and RHEL. I'm using the flatpak version of firefox 88. Tried with safe mode, same issue. Tried with disabled hardware acceleration, same issue. Tried with both HWA disabled and Safe mode, same issue. It's a little weird that videos are flawless in brave browser..

Is there some obscure setting in about:config that I can fiddle with?

Chosen solution

found out that flatpak firefox needs ffmpeg installed on the runtime with the following command:

sudo flatpak install flathub org.freedesktop.Platform.ffmpeg-full/x86_64/19.08 org.freedesktop.Platform.ffmpeg-full/x86_64/20.08

videos works great!

source: https://www.reddit.com/r/Fedora/comments/k7s9xu/firefox_choppy_video_playback_on_fedora_33_amd_gpu/gevfk1u?utm_source=share&utm_medium=web2x&context=3

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

found out that flatpak firefox needs ffmpeg installed on the runtime with the following command:

sudo flatpak install flathub org.freedesktop.Platform.ffmpeg-full/x86_64/19.08 org.freedesktop.Platform.ffmpeg-full/x86_64/20.08

videos works great!

source: https://www.reddit.com/r/Fedora/comments/k7s9xu/firefox_choppy_video_playback_on_fedora_33_amd_gpu/gevfk1u?utm_source=share&utm_medium=web2x&context=3

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.