Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove close-window-button or remove the whole tab part in fullscreen without GNOME topbar

  • 4 replies
  • 1 has this problem
  • Last reply by wyt94yx

more options

Is there any way to remove the close-window-button or the whole tab part. I want to avoid the user close the browser. I know there is Kiosk mode, but kiosk mode seems cannot keep back button

Attached screenshots

All Replies (4)

more options

You can modify your userChrome.css file to hide the tabs and close window button.

Firstly, create a userChrome.css file. Refer to the link below for step-by-step instructions. How to Create a userChrome.css File

Secondly, for the CSS code, refer to jscher2000's solution in a previous thread below. Remove Tabs on Top

Helpful?

more options

Hi strafy, Thank you for your help. I create userChrome.css and enable toolkit.legacyUserProfileCustomizations.stylesheets. Then, I use the code from the link "Remove Tabs on Top". But it still display as normal firefox browser.

Helpful?

more options

Hi strafy, My firefox version is 78.9. After I remove the line "@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");", firefox will not show tab bar and close button!! Thank you!! But the GNOME top-bar is still there. And, there is a "quit" in the menu. How to remove menu button?

Modified by wyt94yx

Helpful?

more options

Hi strafy, My setting in userChrome.css is as following.

/* Hide all tabs and tab bar buttons */ #main-window:not([extradragspace="true"]) #TabsToolbar > .toolbar-items {

 opacity: 0;
 pointer-events: none;

}

/* This makes the bar shorter vertically but removes the 3 window buttons */ #main-window #TabsToolbar {

 visibility: collapse !important;

}

/* For full screen mode */ #TabsToolbar[inFullscreen]{

 visibility: collapse !important; 

}

/* Hide SearchBar */ #urlbar {visibility: collapse;}

/* Hide Hambergur Menu */ #PanelUI-menu-button {display: none;}

Right now, it still has 3 problem. 1. still can't open firefox in fullscreen mode 2. In this way, it is not like Kiosk and there is the right-click menu. How to disable right-click menu?

Thank you.

Modified by wyt94yx

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.