Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Site information (security / lock icon menu) not displaying correctly in Nightly

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by jscher2000

more options

So this visual bug has been happening on my Nightly install for months now. The "Site information for website.com" menu that appears when you click the lock icon in the address bar is basically unusable for me. The menu's header, "clear cookies" button, and arrow button are all fine, but the text in between is covered in globe icons. The "Connection Security" sub-menu that the arrow leads to has a similar case. (See screenshot.)

Huge disclaimer: I am using Shadowfox, which modifies a Firefox install to make UI elements darker. It has made text difficult to read for me at times, but it has never produced any really strange artifacts like this one as far as I can tell. I do have a Developer Edition install with no Shadowfox and it doesn't have the issue. However, maybe this is a common Nightly issue. (I guess this wouldn't make sense since DE is even more experimental than Nightly? I think?)

Maybe this is a problem for the Shadowfox team. Ultimately, the solution I really want is native support for a full-fledged dark mode, with black or gray color for UI elements such as the context menu. If this isn't going to happen and Shadowfox is indeed the source of the issue, I'll gladly let them know. But I thought it would be good to share with Mozilla, and why not the community, too. (Feedback tool is down right now.)

Attached screenshots

All Replies (1)

more options

This is an old issue with Shadowfox: https://github.com/overdodactyl/ShadowFox/issues/284

You can get most of Firefox's UI dark with the following combination, but not context menus yet, for some reason. The UI is undergoing another redesign: "Proton" will replace "Photon". I don't know whether it is premature to investigate how dark themes might work in Proton; there's more about it on Reddit than on this forum.

For Firefox 87-Nightly (without Proton):

(A) Use the built-in dark theme

(B) Override system theme preference to dark

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box, type or paste ui.systemUsesDarkTheme

(3) Firefox should display a bar with some radio buttons to choose a new preference type, followed by a + button. Choose Number and click the + button:

(D) Edit the value to either 0 (Light) or 1 (Dark) and then click the blue check mark button or press Enter/Return to save the change.

Success?