Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird and Rogers Yahoo

  • 1 reply
  • 1 has this problem
  • 19 views
  • Last reply by sfhowes

more options

I have two email accounts with Rogers where I use Thunderbird on my PC as an email client. Rogers recently forced changes to my account to require an an OAuth2 authentication method. Rogers itself was unwilling to provide me with any direction as to how to do that and after much trial and error I have been able to configure Thunderbird to receive emails, but I can send on only one of the email accounts. On account #1 - The inbound email settings are set to a server setting of pop.mail.yahoo.com, Connection Security ssl/tls and authentication Oauth2; the outbound server is smtp.broadband.rogers.com with the user name being the account email; it works fine. On account #2, the inbound settings are the same except for the account email. It works fine. On account #2 the outbound server settings are also smtp.broadband.rogers.com. However if i add the email for the second account to the user name on the outbound settings it then blocks the first. Clearly I am doing something wrong when configuring the outbound server settings but I cannot figure out what to do.

I have two email accounts with Rogers where I use Thunderbird on my PC as an email client. Rogers recently forced changes to my account to require an an OAuth2 authentication method. Rogers itself was unwilling to provide me with any direction as to how to do that and after much trial and error I have been able to configure Thunderbird to receive emails, but I can send on only one of the email accounts. On account #1 - The inbound email settings are set to a server setting of pop.mail.yahoo.com, Connection Security ssl/tls and authentication Oauth2; the outbound server is smtp.broadband.rogers.com with the user name being the account email; it works fine. On account #2, the inbound settings are the same except for the account email. It works fine. On account #2 the outbound server settings are also smtp.broadband.rogers.com. However if i add the email for the second account to the user name on the outbound settings it then blocks the first. Clearly I am doing something wrong when configuring the outbound server settings but I cannot figure out what to do.

All Replies (1)

more options

Unless you can send on the Yahoo smtp, smtp.mail.yahoo.com, I think you'll have to use smtp.broadband.rogers.com with an app password in TB instead of the account password. TB does support OAuth2 for the Yahoo servers, incoming and outgoing, but not for the Rogers smtp. You should also make sure each account sends over an smtp that shares the same User Name (email address): select an account in the left pane of Account Settings, then choose the smtp in the right pane drop-down with the same User Name (not all accounts sending on the same, Default smtp). To switch from an account password to an app password, remove the password from Saved Passwords in Options, restart TB, and enter the app password when prompted.

https://www.rogers.com/customer/support/article/email-setup