Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure Connection Failed on every single website

  • 11 replies
  • 1 has this problem
  • Last reply by boyett

more options

I'm getting Secure Connection Failed error on every single website I try to visit. Including sites such as microsoft.com, duckduckgo.com, google.com, etc. (Strangely, mozilla.org works fine.) Try Again never works, and Advanced - Accept risk works sometimes, but not always and if I close Firefox app and re-open it's back to the error page. I can't believe this is a common problem, so there must be something about my phone that's causing this. Android 11. Happens whether or not WiFi is enabled. What could it be?

Modified by don.wingate

Chosen solution

Do you have any add-ons installed?

Are you using any antivirus or security apps on your Android device?

Read this answer in context 👍 1

All Replies (11)

more options

Hi

What is the version number of the copy of Firefox for Android installed on your device?

Helpful?

more options

Hi

Firefox Version 86.1.1 I have also installed Firefox Beta version 87.0.0-beta-6. It has the same issue.

Thanks.

Helpful?

more options

Chosen Solution

Do you have any add-ons installed?

Are you using any antivirus or security apps on your Android device?

Helpful?

more options

Yes, that's it. I have the AdGuard app installed. Disabling it solves the problem. But Firefox is the only browser that has a problem with AdGuard. Edge, Opera and Chrome all work fine with it. Is this a problem with AdGuard or Firefox?

Edit: Problem solved. AdGuard has an app specific setting for filtering https traffic. For some reason it was turned on for Firefox by default, but not the other browsers. Turning it off solved the problem.

Thank you.

Modified by don.wingate

Helpful?

more options

I think you would be best served by contacting the Adguard support team as it may be the case that they have not retested their app further to the work we did last summer to five Firefox for Android a considerable upgrade.

Helpful?

more options

Problem solved. AdGuard has an app specific setting for filtering https traffic. For some reason it was turned on for Firefox by default, but not the other browsers. Turning it off solved the problem.

Helpful?

more options

I have the same problem on a Samsung S9+ with Firefox as the default browser. Could you please specify exactly where I can find the list of allowed browsers in the AdGuard settings? I've searched without success.

Helpful?

more options

Look under Apps Management, find Firefox and select, then scroll down to Settings->HTTPS Filtering.

That fixed it for me. But I don't know what the potential downside might be. I just experimented with turning the setting on for Chrome and Edge and they still seem to work fine, so something weird does seem to be going on.

Modified by don.wingate

Helpful?

more options

It works! Thank you so much, I was looking in "Settings" from the main menu and didn't think of looking in Apps Management. I think I'll copy your solution on Mozilla's forum, it might wake someone up, there. Thanks again.

Helpful?

more options

Oops, I meant on AdGuard's forum!

Helpful?

more options

I got the same problem with Firefox just recently. Actually, I turned on the HTTPS Filtering long time ago for my all browser (Samsung Internet, Brave, Chrome, Firefox) and it`s all working fine even until now. Only the Firefox got an issue.

Modified by boyett

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.