Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TB compact seemingly fails with incorrect savings amount (win10)

  • 2 replies
  • 1 has this problem
  • 8 views
  • Last reply by gateway7

more options

Hi,

I have TB 78.4.0 32-bit and am holding at that version until some add-ons are updated. Ever since upgrading to the 7x version of TB, folder compacting does not seem to work. I have the option checked to compact when it would save 250MB. What happens is that I delete a message, TB prompts me to compact, I say yes, it tries to compact, and then the next time I delete a message it prompts me to compact again.

Not only does the amount of space it claims I will save by compacting unchanged on subsequent prompts, but over the months it continues to get larger - right now it says I will save over 1GB. It makes no difference if I have it prompt me or just compact automatically.

When I click on compact I have tried switching away and doing something else for an hour or two to make sure I'm not interrupting it somehow, so I don't think it's that.

What I have noticed is that it seems to start compacting local folders, and then gets "interrupted" by attempting to purge my main Yahoo IMAP account (all the others are gmail). It'll say something like "Compacting Local Folders: Trash" and then suddenly the status bar switches midway to logging into the IMAP, it attempts to purge the IMAP inbox, and then it figures it's done and quits after checking the IMAP folders. It doesn't continue/resume the local folder compacting. I'm pretty sure it thinks it's finished, since it says that compacting is complete and I've saved 1.2 GB, and then 5 minutes later when I delete a message it tells me that I need to compact to save 1.2 GB of space and the same thing starts all over again.

I've tried right-clicking on individual mail folders to compact them one by one from the menu, but that appears to do nothing - it doesn't even try to compact.

Does anyone have any ideas on how I can get compacting to work again?

Thanks!

Modified by Wayne Mery

All Replies (2)

more options

Your issue is described at https://bugzilla.mozilla.org/show_bug.cgi?id=1260698 I've been looking for someone who can reproduce this.

I'd like to ask that you don't change anything yet, so we can determine how to do the forensics on your system.

Helpful?

more options

Sure, I'll stand by and wait to hear back. Good to know I'm not the only one who's seen this. Glad to help out any way I can.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.