Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is unable to load anything - not even the new tab page

  • 3 replies
  • 1 has this problem
  • 5 views
  • Last reply by jscher2000

more options

This started when I got a dll error earlier when I tried to restart Firefox, and it recommended reinstalling the browser. I did that. Now the error was gone but... nothing loaded. I tried to refresh and to boot it in safe mode. Nothing. I tried uninstalling the browser entirely by deleting it and all files associated with it and reinstalling. Didn't fix things. I tried uninstalling and reinstalling Visual C++. Still, not a single thing loads.

Chosen solution

In my case, I found a dedicated page to get the latest installer for the shared VC Runtime files:

https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0

I downloaded and ran both the 32-bit and 64-bit installers in the first section of that article ("Visual Studio 2015, 2017 and 2019"). Then I restarted Windows and all was normal again.

I don't know whether 64-bit users need the 32-bit install, but Windows didn't object when I ran it (I ran it first, then 64-bit second).

Are those the ones you already installed? Perhaps you might also need to re-run the Firefox installer. You can re-download from here (and no need to uninstall what you have):

https://www.mozilla.org/firefox/all/#product-desktop-release

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

In my case, I found a dedicated page to get the latest installer for the shared VC Runtime files:

https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0

I downloaded and ran both the 32-bit and 64-bit installers in the first section of that article ("Visual Studio 2015, 2017 and 2019"). Then I restarted Windows and all was normal again.

I don't know whether 64-bit users need the 32-bit install, but Windows didn't object when I ran it (I ran it first, then 64-bit second).

Are those the ones you already installed? Perhaps you might also need to re-run the Firefox installer. You can re-download from here (and no need to uninstall what you have):

https://www.mozilla.org/firefox/all/#product-desktop-release

Helpful?

more options

jscher2000 said

In my case, I found a dedicated page to get the latest installer for the shared VC Runtime files: https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0 I downloaded and ran both the 32-bit and 64-bit installers in the first section of that article ("Visual Studio 2015, 2017 and 2019"). Then I restarted Windows and all was normal again. I don't know whether 64-bit users need the 32-bit install, but Windows didn't object when I ran it (I ran it first, then 64-bit second). Are those the ones you already installed? Perhaps you might also need to re-run the Firefox installer. You can re-download from here (and no need to uninstall what you have): https://www.mozilla.org/firefox/all/#product-desktop-release

Funny thing about that lol, I actually read your fix while troubleshooting earlier (before I posted here), and none of these worked sadly. I wish they did though, otherwise I probably wouldn't have thought of VC being the issue. Sadly, it wasn't, so we're kind of back to square one on this.

Helpful?

more options

Sorry, I didn't mention that including a non-Mozilla URL in your reply (even quoting from me) diverts your post to the link spam moderation queue. It should appear eventually.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.