Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Login failures

  • 2 replies
  • 1 has this problem
  • 9 views
  • Last reply by free3ist

more options

I use 85.0.2-64 bit on a PC.

For the last month or so. Perhaps since the last update or two. I can't login to my bank.

Details:

-I try it on Edge, and it works.

-When it fails, I get the bank website's standard failure error message: "Your username and/or password are incorrect. Please try again";

-I've repeatedly checked on the correctness of my ID & PW repeatedly over the last month;

-I use Norton PW manager, but I have back-up on a secure thumb drive. I try the PW using my backup, and it still fails;

-I try typing my ID & PW in manually, and it still fails;

-The only successful workaround on Firefox is to change my PW. Then I can login: once;

-I do have add-ons, but I deactivated all of them, restarted Firefox, and it still fails.

I've used Firefox for decades, but not being able to do simple banking is a strong argument for using Edge. Do you have a remedy or a suggestion for this?

Chosen solution

This issue can be caused by corrupted cookies or blocked cookies.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

This issue can be caused by corrupted cookies or blocked cookies.

Helpful?

more options

Problem solved. Operator error. Turns out I wasn't as thorough about deactivating those add-ons as I thought. U-Block Origin setting. But it wasn't doing that before, of course.

Thanks

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.