Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Accounts and mail dissappeared in Thunderbird 78.7

  • 3 replies
  • 1 has this problem
  • 247 views
  • Last reply by fivezip50

more options

I have Thunderbird 78.7 on Windows 10. When I started it just now, the only thing I saw was the welcome screen.

My Profiles folder is in the same place as it was before, the files containing mail are the, and the folders seems to be accessed by TB, but I can't find my accounts, folders or emails anywhere in TB.

Followed the instructions in this thread: https://support.mozilla.org/en-US/questions/1270964, deleted my global-messages-db.sqlite file and restarted TB, but still nothing. Just the Welcome screen, no reindexing.

There does appear a new global-messages-db.sqlite after starting TB.

I also did a re-install of TB, but that didn't help either. I am completely out of ideas, to be honest.

Thanks in advance!

Chosen solution

Open the profile folder and see if there are files like prefs-1.js, prefs-2.js, ..... Open the newest one in a text editor and see if it has the correct account data, and if so, rename prefs.js to prefs.js.bak, and rename the prefs-N.js file that looks correct to prefs.js, then restart TB.

http://kb.mozillazine.org/Recovering_a_profile_that_suddenly_disappeared

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Open the profile folder and see if there are files like prefs-1.js, prefs-2.js, ..... Open the newest one in a text editor and see if it has the correct account data, and if so, rename prefs.js to prefs.js.bak, and rename the prefs-N.js file that looks correct to prefs.js, then restart TB.

http://kb.mozillazine.org/Recovering_a_profile_that_suddenly_disappeared

more options

That dit it! Can't believe I didn't find the link myself. Thank you very much for your effort.

more options

Hi I'm having this same issue.

I just tried renaming the prefs.js to prefs.js.bak and the prefs-N.js file to prefs.js but it still does exactly the same thing.

Under the "Get Messages" dropdown I can see all of the accounts that I normally use, but the main window just won't populate.

A few weeks ago I copied by entire TB folder across from another computer (Windows 7 to Windows 10) and it was working fine until yesterday.

I tried deleting the entire TB folder and copying it over again from my old computer but now it's still got that error.

I feel like it's an issue with Windows 10.

Any other ideas?

Modified by fivezip50