Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't edit Zoom Scheduling using Firefox

  • 5 replies
  • 1 has this problem
  • 10 views
  • Last reply by jscher2000

more options

In my Zoom Scheduling account, when I go to edit a zoom meeting (using firefox browser) it automatically sends me into the meeting, and won't let me edit any details. I have the Zoom plug ins installed, but nothing is helping. Every other browser (Chrome, and Safari) are working as expected. This is only happening when I am using Firefox. Please help!

Attached screenshots

All Replies (5)

more options

Although the Start button is highlighted, does the Edit button enable if you mouse over it? This is on Windows, in case that matters:

Or is the problem that the Edit button also starts the meeting?

Helpful?

more options

That’s the problem. When I click on the edit button, it opens up the meeting! All other browsers, it works fine. Except Firefox!

Helpful?

more options

That's so strange, I wonder what is different between mine and yours.

For my sample meeting, when I mouse over the Start button, Firefox shows this link in the lower left corner:

https://us02web.zoom. us/s/86191908728

and when I mouse over the Edit button, it shows this link:

https://us02web.zoom. us/meeting/86191908728/edit?listType=upcoming

(The spaces were just inserted for posting)

If you mouse over the two buttons, do they both show the start link?

Helpful?

more options

Yea. So strange. I’m also on a Mac mini M1.

Helpful?

more options

It's difficult to think of why an extension might be modifying the link, but could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.