Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spell check not working on some websites and some new features on Facebook

  • 8 replies
  • 1 has this problem
  • 56 views
  • Last reply by Big Steve

more options

My Veterans Group recently moved their Ning website from a Ning2.0 website to a Ning3.0 website. On the old website the browser spell check worked fine on all text boxes. On the new site it only works in a few text boxes, in most it doesn’t work (the right click menu doesn’t even show a spell check option in those text boxes). I also noticed the same issue on the Ning creators website (which I believe is a Ning3.0 based site).

Also spell check is not available in the new facebook share pop up window’s text box.

Is this something that needs updated I the browser?

Chosen solution

A JavaScript bookmarklet is created just like a normal bookmark, you only paste the full JavaScript code in its location field instead of the URL.

For the TinyMCE editor you can also try this code:

javascript:void(document.querySelector("iframe[id$=\"ifr\"]").contentDocument.body.setAttribute("spellcheck","true"))

(edited for code that hopefully works)

Read this answer in context 👍 1

All Replies (8)

more options

I accidentally found on Ning 3.0 based websites that switching from their standard edit window to their HTML edit window allows spell check to function (unfortunately in addition to finding misspelled words it also thinks some of the HTML code is also misspelled).

Helpful?

more options

A webpage can disable the Firefox spell checker via a spellcheck="false" attribute of an input field or textarea or editable element and possibly provide its own spelling checker.

You can right-click in the text area or input field and use "Inspect Element" to check in the Inspector if this text area has a spellcheck="false" attribute.

You can remove this spellcheck="false" attribute or change it to spellcheck="true" via a double-click or via "Edit As HTML" to make the "Check Spelling" item in the right-click context menu reappear.

Also make sure that the correct dictionary is selected in the Languages sub menu.

Helpful?

more options

cor-el,

The spellcheck="false" attribute appears to be set on all discussion text boxes on Ning 3.0 websites. I can temporarily restore the spell check by changing the attribute to "true" per your instructions. I'm assuming that the site has to be edited at the source to really solve this issue.

Thanks!!

Helpful?

more options

It is possible to use a JavaScript bookmarklet on the Bookmarks Toolbar to remove this spellcheck attribute, but it depends on how this is setup for what code to use.

For a plain text editor like on this forum this should work.

  • javascript:void(document.activeElement.setAttribute('spellcheck','true'));

For an HTML type editor you can try this code:

  • javascript:void(document.activeElement.contentDocument.querySelector('*[spellcheck]').setAttribute('spellcheck','true'));

Otherwise use the Inspector to check what code you need to target this element.

This JavaScript works for the currently active element, so you need to set focus to the text area (click to place the cursor in it) before you click the bookmarklet.

Helpful?

more options

This is what I see in inspector:

<body id="tinymce" class="mce-content-body theme-982" data-id="description" spellcheck="false" contenteditable="true">


</body>

I've never created a JavaScript bookmarklet. Can you point me to a tutorial on how to do that?

Would that continue to work as I surf the site, or would an bookmarklet have to be created for every page? I currently have posted a question on Ning's support website to see if the website can be modified through some CSS code, but I haven't received a response from any of the "gurus" there.

Helpful?

more options

Chosen Solution

A JavaScript bookmarklet is created just like a normal bookmark, you only paste the full JavaScript code in its location field instead of the URL.

For the TinyMCE editor you can also try this code:

javascript:void(document.querySelector("iframe[id$=\"ifr\"]").contentDocument.body.setAttribute("spellcheck","true"))

(edited for code that hopefully works)

Modified by cor-el

Helpful?

more options

It may be I'm just getting stupid in my old age, but it seems like I'm trying to read Ancient Greek when I read your instructions and even when I go to this Mozilla How to page: https://support.mozilla.org/en-US/kb/bookmarklets-perform-common-web-page-tasks

I'm not sure what I'm missing? :(

Helpful?

more options

I found a youtube video by a guy in the UK that explains how to write the code (once again it was all Greek to me) and he included a link to a page he created that will make a bookmarklet. I copied and pasted cor-el's code in the appropriate box and voilà it made it for me. So I copied and pasted it to my bookmarks menu and now it will make Firefox inline spell check work on all ning3.0 website's text boxes.

Thanks cor-el for the code. I would have never figured that out. :)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.