Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Search appears in dark mode even when the browser theme is light.

  • 3 replies
  • 1 has this problem
  • 28 views
  • Last reply by cor-el

more options

I'm running on Firefox on macOS Big Sur with dark mode on. Google searches appeared with the normal white background color up until today. Now, the searches only appear with the white background color if I leave my operating system with a light theme. I tried using terminal to override the system background color for Firefox to try and get my searches to appear white again, but this didn't work. I also tried using an app which would run the commands itself (in case I had input the wrong commands), but this also didn't work. The odd thing is that even if I turn the Firefox theme to light or any other color, the Google searches still appear in dark mode. Also Firefox is the only browser where the searches appear in dark mode; in both Safari and Chrome the searches still have a white background. Is there any settings I can change in Firefox to fix this or anything else I can do?

I'm running on Firefox on macOS Big Sur with dark mode on. Google searches appeared with the normal white background color up until today. Now, the searches only appear with the white background color if I leave my operating system with a light theme. I tried using terminal to override the system background color for Firefox to try and get my searches to appear white again, but this didn't work. I also tried using an app which would run the commands itself (in case I had input the wrong commands), but this also didn't work. The odd thing is that even if I turn the Firefox theme to light or any other color, the Google searches still appear in dark mode. Also Firefox is the only browser where the searches appear in dark mode; in both Safari and Chrome the searches still have a white background. Is there any settings I can change in Firefox to fix this or anything else I can do?
Attached screenshots

All Replies (3)

more options

If anyone else was having the same issue as I was, I found the solution here: https://www.reddit.com/r/firefox/comments/dgke1s/help_is_there_a_way_to_disable_dark_mode_websites/ It worked immediately for me.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

more options