Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to Stop Automatic Firefox Update and Pop-up

  • 1 reply
  • 1 has this problem
  • 62 views
  • Last reply by Mike Kaply

more options

Hi Team,

We have created a package for ESR version, but when we tested with older version i.e. 78.4.1. We are not able to stop the Automatic Mozilla Firefox update through script. Attaching the script command:


// Disable Auto Update lockPref("app.update.enabled", false); lockPref("app.update.auto", false); lockPref("app.update.service.enabled", false); lockPref("app.update.mode", 0); lockPref("app.update.BITS.enabled", false); lockPref("app.update.auto.migrated", false); lockPref("app.update.checkInstallTime", false); lockPref("app.update.staging.enabled", false); lockPref("app.update.doorhanger", false); lockPref("app.update.url", "https://google.com/");

Install command that we used is:

msiexec.exe /i "%~dp0FirefoxSetup78.4.1esr_x64.msi" INSTALL_MAINTENANCE_SERVICE=false /qn

======================================================================

echo Script to disable auto update of Firefox using Registry...

======================================================================

REG ADD HKEY_LOCAL_MACHINE\Software\Policies\Mozilla\Firefox /v AppAutoUpdate /t REG_DWORD /d 0 /f

=======================================================================

echo Script for customization firefox ...

=======================================================================

If exist "%ProgramFiles%\Mozilla Firefox\" copy /Y "%~dp0override.ini" "%ProgramFiles%\Mozilla Firefox\browser\" If exist "%ProgramFiles%\Mozilla Firefox\" copy /Y "%~dp0mozilla.cfg" "%ProgramFiles%\Mozilla Firefox\" If exist "%ProgramFiles%\Mozilla Firefox\" copy /Y "%~dp0local-settings.js" "%ProgramFiles%\Mozilla Firefox\defaults\pref"


Same worked perfectly with 68.10. Does anyone has any idea what we are doing wrong.

Chosen solution

Those preferences no longer work to disable automatic updates.

You need to disable updates using policy:

https://github.com/mozilla/policy-templates/blob/master/README.md#disableappupdate

None of those other preferences are necessary.

Read this answer in context 👍 1

All Replies (1)

more options

Chosen Solution

Those preferences no longer work to disable automatic updates.

You need to disable updates using policy:

https://github.com/mozilla/policy-templates/blob/master/README.md#disableappupdate

None of those other preferences are necessary.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.