Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lock Proxy Setting FireFox 76.0.1

  • 4 replies
  • 1 has this problem
  • 23 views
  • Last reply by AMAN ARYAN

more options

Hello,

I need to secure the proxy from users, users can't modify the information and they should be locked.

I've been looking for the method and i've created 2 files mozilla.cfg and local-settings.js when i go to see the proxy setting they are not grey and it can be modified i don't know what is the reason at all ...

mozilla.cfg content :

//

// Disable updater

lockPref("app.update.enabled", false);

// make absolutely sure it is really off

lockPref("app.update.auto", false);

lockPref("app.update.mode", 0);

lockPref("app.update.service.enabled", false);

lockPref("network.proxy.type", 0);

local-settings.js content :

//

pref("general.config.filename", "mozilla.cfg");

pref("general.config.obscure_value", 0);

Path :

Mozilla.cfg = C:\Program Files\Mozilla Firefox

local-settings.js =C:\Program Files\Mozilla Firefox\defaults\pref

Attached screenshots

Modified by ZNoct

All Replies (4)

more options

To access proxy settings in Mozilla Firefox, click on Firefox's menu and go to Options. Click the “Advanced” icon at the left side of the Preferences window, click the “Network” tab at the top of the window, and then click the “Settings” button under Connection. You can select four different proxy options here

Helpful?

more options

Hi,

Please see this.

The settings you may want to lock are network.proxy.http and network.proxy.http_port or network.proxy.autoconfig_url

...............................................................................................................................

Useful links:

All about Tools > Options

Going beyond Tools > Options - about:config

about:config Entries

What's That Preference? add-on - Quickly decode about:config entries - After installation, go inside about:config, right-click any preference, enable (tick) MozillaZine Results to Panel and again right-click a pref and choose MozillaZine Reference to begin with.

Keyboard Shortcuts

Firefox Profile Folder & Files

Safe Mode

Problematic Extensions/Add-ons

Troubleshooting Extensions and Themes

Helpful?

more options

I think that your code should work (works for me).

Did you check the Browser Console for possible error messages ?

The autoconfig.cfg file is placed at the top level of the Firefox directory.

  • autoconfig.cfg and autoconfig.js need to start with a comment line (//)
  • autoconfig.js needs to use Unix line endings (LF instead of CR/LF)

See also:

Helpful?

more options

hello, you could try to take a look if the settings are locked like described in this article: http://kb.mozillazine.org/Locking_preferences

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.