Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some text is covered with black diamonds and question marks

  • 11 replies
  • 1 has this problem
  • 56 views
  • Last reply by Prentice3

more options

On FoxNews.com, some articles include a section at the bottom for user comments. First-level comments frequently receive additional second- and third-level comments.

First-level comments are working fine, but lower-level comments are partially obliterated with a string of black diamonds with question marks �?U��N�@?�.

This is not an issue when I use Safari, but it is on Firefox.

Attached screenshots

All Replies (11)

more options

That is a problem with fonts.

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1


Also see: https://support.mozilla.org/en-US/search/advanced?q=fonts&language=en-US&product=firefox&sortby_documents=relevance&a=1&w=1

Helpful?

more options

Fred, Thank you for responding. Unfortunately, this did not resolve the issue. The box for "Allow Web Sites to Chose Their Own" was already checked.

The text at issue is partially displayed and looks perfectly normal. If the comment is lengthy, most of it is displayed; the black diamonds and question marks only cover the first five lines.

Please see attached image.

Helpful?

more options

I called for more help.

Helpful?

more options

The little > showing to whom the reply was directed isn't just a > character, it is an image created by an SVG element. So perhaps something in your Firefox doesn't like SVG elements and is barfing them up as binary code?

Helpful?

more options

Thank you for the suggestion. I found Scalable Vector Graphics in the Firefox Preferences..General..Applications window. It was set to "Open In Firefox". I set it to "Always Ask", completely shut down Firefox and brought it up again. No change. I then set it to "Use MacOS Default Application", shut down Firefox and brought it up again. No change.

Modified by Prentice3

Helpful?

more options

What does the HTML code look like if you check this '>' image in the Inspector ?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

Are there messages in the Web Console that look related ?

Helpful?

more options

Thank you for taking an interest in my problem.

"The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it." This error message appears six consecutive times which seems to coincide with the six lines of garbled text. In this case, the error is at the second indent level (a reply to a reply). When the error occurs at the first indent level (a reply to a comment), this error message appears five consecutive times.

I took a screenshot of the Web Console.

Helpful?

more options

Is anyone at mozilla monitoring these support requests?

I think jscher2000 and cor-el were right on-target with the ">" being the root of the problem.

Helpful?

more options

SVG is used for a lot of icons and logos on the web, so if it's a general problem with your FIrefox rendering SVG, you would see issues on a lot of sites. Is this the only place where you see anything like that?

Can you tell whether your Norton add-on is blocking anything on the page? Possibly if you click its toolbar item it will report what it's doing.

Helpful?

more options

This is the only place I'm having any problem at all. Everything is running quite well, and I see lots of icons and logos properly displayed.

I checked Norton for a problem report and found nothing. So, I closed everything on my computer, then stopped Norton and brought up Firefox. Still had the problem. Of course I immediately resumed Norton after that.

I also brought up Chrome which I do not use. I let Norton install its extensions for Chrome and then brought up FoxNews. No problem there.

Helpful?

more options

Cannot explain why, but everything is working properly today. Text comments are displaying properly; yesterday they were not. I don't believe I did anything that would explain the change.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.