Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Emails containing text plus ICS don't show the text

  • 17 replies
  • 6 have this problem
  • 83 views
  • Last reply by seanmk

more options

[Nov 17 I deleted "TB78" from the subject line when I realised the problem goes back earlier.] ICS makes message text invisible!

I have an online booking system and I can send and receive email messages to and from my clients via this. These emails contain both a text message, plus an ICS of the appointment the message relates to. All was well until I updated to TB78. Previous TB would show me both the information in the ICS file in an unboxed freeform format, plus the vital text message from my client at the top of the screen.

Now that is broken. First - this bit is not broken, this is just different - the ICS appears in a blue box in a structured layout. And - BIG problem - the text message appears nowhere in the email, neither before, in or after the blue ICS box. Ie the point of the email, the actual message, is not shown!

The problem is with TB78. If I go back to emails from before TB78 in which I could previously read the message, the message has no longer displayed. And if I access any of these emails in webmail, they all have to the old freeform unboxed format and the message perfectly visible.

This looks very like a bug in TB78 and I hope can be fixed or a setting that changes it.

Many thanks

Modified by Andrew3142

All Replies (17)

more options

If the text part was attached, it won't appear inline unless mail.inline_attachments.text is double-clicked to true in Config. editor (Options/General). This was a change from previous versions. Does that make a difference?

Helpful?

more options

Thank you, but no, no change. The text part is in any case not attached, it is just regular email text. Only the ICS is attached.

Helpful?

more options

Does the text portion appear in the Message Source (Ctrl+U)? If the message was sent from a phone app, the text might not appear in the conventional way. In Config. editor, double-click mailnews.display.show_all_body_parts_menu to true, and then set View/Message Body As to All Body Parts and see if the text appears as an attachment.

Helpful?

more options

Yes, that does something. In Ctrl-U the message is there, in the section "Content-Type: text/plain; charset="utf-8"" And with All Body Parts on, the message appears as an attachment.

However it's not because it's coming from a phone app, because this is a test message I sent from my laptop.

Progress!

Helpful?

more options

What's selected under View/Text Encoding? Is the Text Encoding for Incoming Mail set to UTF-8 in Options/General/Language & Appearance, Advanced...?

Helpful?

more options

Under advanced it was set to Western ISO-8859-1 so I changed it to UTF-8 and View > Text encoding was then also Unicode; but, no difference.

However, I discovered two things. (1) View > Message Body set to All Body Parts causes the wanted message to appear in two, not one, attachments. Before I saw one tiny plain text attachment with just the message text. I've now realised there is a big HTML attachment which contains all the information, both the message text and the calendar information, in exactly the format I need and which TB used to show things in. (attached image.)

It is as if before TB78, TB was showing THIS HTML attachment as the email content. Now, it is showing just the ICS file as the email content.

(2) If with View > Message Body set to All Body Parts I then do Message > Edit as new message, then the wanted text appears as the text of the new email, even though this text was completely invisible in the original message and only showed in the attachments.

Is there anything I can upload to make this clearer?

Helpful?

more options

So far, the problem is clear, but I don't know the solution or cause. There are a number of bugs that may be relevant. One user had success by testing in a new profile, and that is certainly worth trying. Help/Troubleshooting, about:profiles, create a new profile, add an account, and see if the attachments appear differently, after switching the inline preference. The original profile is unaffected.

Helpful?

more options

Yes, new profile worked. Very good. What I get is 3 attachments one after the other - first the plain text UTF file, then the HTML version I uploaded, finally the ICS file in its blue box. ( I also get a message saying "no calendar enabled" and since I don't use calendars I don't know how to enable one, so I didn't test if enabling one will mess things up again. )

Can I just import my other email accounts into the new profile and abandon the old one? Can I then make the new profile the default?

Many thanks for your help. It's late here in the UK so no more from me tonight.

Helpful?

more options

For IMAP accounts, just add them to the new profile and mail on the server will download. For POP accounts and local mail, Help/Troubleshooting, Profile Folder, Open Folder to open the current (old) profile, close TB. Open Mail/<popservername> or Mail/Local Folders, copy the mbox files (large files with no extension, named after folders) to Mail/Local Folders of the new profile. Copy abook.sqlite and history.sqlite from the old profile to the new. Other data can be transferred if necessary. Set the new profile as default in about:profiles.

Modified by sfhowes

Helpful?

more options

Good and bad progress. Good - I didn't need to set up a new profile. Windows updated and after the reboot the original profile implements the workaround. And, as above, the results is that TB displays the lost information in an adequate though somewhat kludgy layout.

[ The workaround, per sfhowes post above is: In Config. editor, double-click mailnews.display.show_all_body_parts_menu to true, and then set View/Message Body As to All Body Parts ]

Bad - with the workaround set, the display of many previously unproblematic emails collapses into unreadability, though they are fine if I reset View > message body as to Original HTML.

This, I can see some emails OK, or others, but not all.

At some point I will try to revert to TB68 and see if that fixes things. If I do, I'll report here.

Helpful?

more options

I reverted to V 68 - interesting! The problem is not V78 as such. The problem is Lightning, even in V68.

I installed V68.12.1 as a separate program. This launches with Lightning enabled by default, and this causes exactly the problem I had in V 78 - ie the actual textual email message cannot be seen or found, only the accompanying ICS file.

I disabled Lightning, and then the message appears and all is well. I've no interest in the calendar so I've never previously had Lightning installed. In V78 I can't escape it.

So this looks like a real bug. It may not be readily apparent because the messages that cause the problem are booking-system-generated with a mixture of user input and booking system input. I'd be happy to forward a problem email to someone, if that helps.

I end up with a problem, because the question isn't can I read these message, the question is whether my customers can. This means that if my customers use Thunderbird, they can't read messages from my booking system. I hope this can be fixed.

Helpful?

more options

To bring it to the attention of the developers, you could try submitting it to Bugzilla, or post the issue in this Calendar forum. It might be disregarded due to the unknown effects of the booking system software.

Helpful?

more options

I reported it in Bugzilla and I'll look at the forum. Thank you for your most useful input.

Helpful?

more options

After reading through this thread, I was interested in looking at Andrew's bug report. I couldn't find it, but I found this 4 year old report describing the same issue: Bug 1283683 - When ICS attached, Lightning enabled ONLY event is visible not the email

Jobst Schmalenbach provides an extremely simple workaround: View > Display Attachments Inline. Checked will show the event summary, unchecked will show the body. No fiddling with Config Editor necessary.

Modified by AsanaWiosna

Helpful?

more options

View > Display Attachments Inline doesn't help my problem at all unfortunately, I already tried it. Only the more elaborate workaround above helps. Thank you for finding this old bug. I've closed my report and joined with the old one.

Helpful?

more options

Also having this problem, If I enable "All Parts", the text appears as multiple attachments which have to be opened to understand. The only item that "renders" in a message pane or separate tab is the invitation itself. Absolutely nothing, nada, anything else. Only noticed this since the message displays properly when using ANY OTHER mail application but Thunderbird. Multi-part message display appears to be a problem with built in Lightning intercepting the ICS and preventing the display of any other message body parts.

Helpful?

more options

I am also having this problem. I wouldn't have realized that text was hidden except that I sent an email to myself with an ICS file attached and I couldn't see the message body. The email was sent from GMail, so there's no way to modify the headers from the sender. Even with some workarounds, this seems like a bug since it is most certainly unexpected behavior.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.