Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stop Thunderbird marking a thread as read?

  • 11 replies
  • 1 has this problem
  • 143 views
  • Last reply by sfhowes

more options

I have disabled automatic marking of messages as read after 5 seconds. When I read a message, I mark it as read by hand using the "R" keyboard shortcut. And here comes the problem. When one person sends me 5 e-mails and I mark one e-mail as read, all e-mails automatically become marked as read!

I understand that Thunderbird treats these 5 emails as a thread and marks the entire thread as read. How can I stop Thunderbird marking a thread as read?

Best regards

All Replies (11)

more options

re :I understand that Thunderbird treats these 5 emails as a thread and marks the entire thread as read. How can I stop Thunderbird marking a thread as read?

If the thread is collapsed and you mark the top level as read then all get marked as read. If you expand the thread and mark one as read then only one is marked as read. This is the standard method and there has been no change to this. It functions the same as previously.

Helpful?

more options

If the thread is collapsed and you mark the top level as read then all get marked as read.

I am not using threads view. I always see all e-mails in the order they were received. I checked and no matter which e-mail I mark as read - all e-mails (5) are always marked as read

Helpful?

more options

Do you have some kind of add-on, such as Conversations, that could be causing this? Help/Restart with add-ons disabled to test.

Helpful?

more options

I had an add-on. I just turned everything off and restarted Thunderbird. Unfortunately, nothing has changed. Still marking one message as read marks all of them

Helpful?

more options

I did a test on an unthreaded folder and marked 3 messages in the same conversation as unread. When I selected one message (making it Read), and pressed R, the other 2 messages were also marked Read. But if I right-click one message, Mark/As Read, only the selected message is marked Read. So, there appears to be a difference between the action of the keyboard shortcut and the (correct action of the) context menu.

Helpful?

more options

I checked it this way, and it works the same on my Thunderbird. Only now how to get around it to work with a keyboard shortcut?

Helpful?

more options

My menu shows the R key to be the shortcut to mark a thread as read. There does not appear to be a shortcut associated with mark an individual message as read.

Helpful?

more options

You're right. I saw it now. So how do you quickly mark individual messages as read? How do I set my own keyboard shortcut?

Helpful?

more options

With tbkeys-lite, I set the m key to mark a message as read (see picture of the add-on's Options).

Helpful?

more options

I noticed that the 'm' keyboard shortcut works without this add-on. Weird. The addon is interesting. Is it possible to set the Ctrl+q shortcut?

Helpful?

more options

So it does, even though I chose m at random. The m shortcut is mentioned here. I think my code is wrong, but it accidentally led to the discovery of the correct key.

I think the add-on documentation mentions that additional keys such as Ctrl are not supported.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.