Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unread emails disappear when cursor on them in Thunderbird 78.4.1 with Windows 7 systems only. Cause: bug 1675970

  • 17 replies
  • 6 have this problem
  • 150 views
  • Last reply by RyanT

more options

Just updated to 78.4.1, and now when I put the cursor on an unread email, the email disappears. That means that the subject, correspondents, and date columns of the email go blank, empty. When the cursor is moved off the email, the columns appear fill in again. No problem with emails marked read, though. Problem persists on reboot into Tbird safe mode with addons disabled. No problems before update.

Modified by Wayne Mery

All Replies (17)

more options

What is your Windows theme? It may cause this blank effect if the theme conflicts with TB Options/General/Language & Appearance, Colors.... Uncheck 'Use system colors' and see if it makes a difference.

The 'hover color' can actually be set with a userChrome.css file.

Helpful?

more options

Thanks for the suggestion. I looked at the system colors check box in Options, and it was already not checked. To experiment a little, I checked it, made no change in the problem, and then returned it to unchecked, made no change in the problem. As to a userChrome.css file, I would not know how to use such file to solve this problem. The problem did not exist for me until literally the moment Tbird updated and restarted today.

Helpful?

more options

Yes, but what is your Windows theme? It may affect TB depending on what you have in TB Colors for the override setting. On my W7 computer with a Windows Aero theme, not high contrast, the hover colors are the default TB colors. TB theme details are under development, which may explain the sudden change. Does using the Light theme help?

I mention userChrome, not because I expect anyone to know about it forehand, but to indicate there is an easy way to apply it.

Helpful?

more options

Thanks. That was informative! I am using Windows 7 with a modified "Classic" theme. So I tried other themes. Problem occurs in "W7 Basic" and "Windows Classic," but NOT in "High Contrast 1" and ditto "2." The problem also disappears in Aero themes such as: "Windows 7," "Nature," and "Landscapes." So it is not high contrast per se that is affecting the appearance of unread emails. I suppose that means that on my modified Classic profile I should find a tweak that makes the problem go away.

Helpful?

more options

Here is the code for hover colors:

treechildren::-moz-tree-row(hover) { background-color:  #f4c2c2  !important; }

#threadTree > treechildren::-moz-tree-cell-text(hover)
{color:blue !important;} 

#folderTree > treechildren::-moz-tree-cell-text(hover)
{color:blue !important;} 

treechildren::-moz-tree-row(hover) { border: none !important; }

Help/Troubleshooting, Profile Folder, Open Folder, close TB, create a new folder named chrome, create a new document in chrome with a text editor, name it userChrome.css, Save as type: All files *.*, copy in the above code, change the colors as desired (see attached pictures). Double-click toolkit.legacyUserProfileCustomizations.stylesheets to true in Options/General/Config. editor, restart TB.

Helpful?

more options

Thanks! I will work on this and report the result.

Helpful?

more options

Yeah, the css file worked! Thanks a lot for your time and assistance!

Helpful?

more options

Just had the same issue - already had a css file to tighten up message list panel spacing, popped in the provided code and all is well! Thanks!

Helpful?

more options

Same problem, W7 Classic. Goes away with high contrast. Tried the css file and it doesn't work. I'd rather not have Microsloth choose my desktop background so, any other suggestions?

Helpful?

more options

Helpful?

more options

.css fix has not worked for me. I have an aversion to patching bugs. With Windows that is like catching a case of the crabs then trying to train them to leashes. Upgrading to a different version of Windows is akin to shaving half your body, setting the other half on fire, then stab at the crabs with an icepick as they run from the flames.

Helpful?

more options

I have same problem. Hesitant to try the css fix, but might end up doing so. As with the OP, this problem just started for me..... it's incredibly annoying, LOL

Helpful?

more options

sfhowes said

Bug report: https://bugzilla.mozilla.org/show_bug.cgi?id=1675970

It looks like they are making headway with a bug fix! Is there any way to get on a list to be notified when it's ready?? Or is this something they will automatically release to all TB users? Thanks so much. You've been incredibly helpful. I absolutely love my TB and Firefox. Mozilla rules!!

Helpful?

more options

The fix might arrive in 78.5 next week. You can create a Bugzilla account and add yourself to the cc list for the bug.

Helpful?

more options

The hover bug in W7 is partially fixed in 78.4.3:

https://www.thunderbird.net/en-US/thunderbird/78.4.3/releasenotes/

but there may still be some anomalies for themes other than Basic.

Helpful?

more options

sfhowes said

The hover bug in W7 is partially fixed in 78.4.3: https://www.thunderbird.net/en-US/thunderbird/78.4.3/releasenotes/ but there may still be some anomalies for themes other than Basic.

FIXED in mine! Works perfectly. Thanks very much............ two thumbs up!

Helpful?

more options

Fixed. And THANK YOU DEVELOPERS EVER SO MUCH! (For not allowing our programs to follow the trendsetting example Windows 95 gave us.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.