Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Email replies getting sent to wrong email address

  • 4 replies
  • 1 has this problem
  • 72 views
  • Last reply by Toad-Hall

more options

I have two email addresses. Recently, when certain persons send me an email on my main address, and I reply to them, they are receiving my reply as if it has been sent from my secondary address. I make sure each time I write to them that it is going from my main address, but for some strange reason, when they reply back I receive it on my secondary address. When I look in "sent mail" the email I sent appears not only in the main address "sent mail" but also in the secondary address "sent mail".

Does anyone know what is going on here? It's very annoying, as the recipients involved are business contacts and this is very confusing for them.

Thanks very much for any help!

Chosen solution

You may have the correct email address in the 'From' but you may actually be sending using another email address' outgoing server smtp.

Check settings:

  • Right click on account name in Folder Pane and select 'Settings'
  • At the bottom of the left pane, below the list of mail accounts and Local folders...

click on 'Outgoing server (SMTP)' It will list all the outgoing serversin the right pane.

  • Select the first one and click on 'Edit'
  • It will show you the email address in the 'user name'.
  • Under 'Description' type that email address.
  • click on OK

Select the second outgoing smtp server in list and click on 'Edit' Repeat the same action to set the 'Description' to say the same email address as mentioned in 'User name'.

Now check to see what Outgoing Server is being used by each account.

  • Select the account name in left pane.

Bottom right it will say 'Outgoing Server (SMTP)' and it will show you the 'Description' information. Make sure the email address shown is the same as the account you have selected.

  • If it is wrong then click on the drop down to select the correct one.

Do not click on 'Edit SMTP-server' button.

  • Check the other mail account to make sure it is using correct outgoing server.

If using version 68*

  • click on OK to close Account Settings.

Restart Thunderbird.

See images below as a guide.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

You may have the correct email address in the 'From' but you may actually be sending using another email address' outgoing server smtp.

Check settings:

  • Right click on account name in Folder Pane and select 'Settings'
  • At the bottom of the left pane, below the list of mail accounts and Local folders...

click on 'Outgoing server (SMTP)' It will list all the outgoing serversin the right pane.

  • Select the first one and click on 'Edit'
  • It will show you the email address in the 'user name'.
  • Under 'Description' type that email address.
  • click on OK

Select the second outgoing smtp server in list and click on 'Edit' Repeat the same action to set the 'Description' to say the same email address as mentioned in 'User name'.

Now check to see what Outgoing Server is being used by each account.

  • Select the account name in left pane.

Bottom right it will say 'Outgoing Server (SMTP)' and it will show you the 'Description' information. Make sure the email address shown is the same as the account you have selected.

  • If it is wrong then click on the drop down to select the correct one.

Do not click on 'Edit SMTP-server' button.

  • Check the other mail account to make sure it is using correct outgoing server.

If using version 68*

  • click on OK to close Account Settings.

Restart Thunderbird.

See images below as a guide.

Helpful?

more options

Thanks for your reply.

I've been using Thunderbird for years, with 2 addresses and this problem started happening on 22 October 2020, I think there's been a Thunderbird update very recently. I certainly didn't change any parameters myself.

I did what you suggested - in my main address panel, effectively the user name on the outgoing server for the main address was the user name for my second address. So I changed that. Then I looked at the second address, which now has the user name for my main address. Both of my addresses being gmail, they are using the same outgoing server. In "outgoing server" I had smtp.gmail.com (default) and smtp.gmail.com. After much hair-tearing, I eventually changed the name of the second outgoing server to "secondaddress" smtp.gmail.com and that seems to have done the trick.

So thanks for your help, problem now solved

Helpful?

more options

Do you mean to say that it is the intentionally designed behavior for Thunderbird to substitute the server login address for the From address chosen in the regular email user interface? I have had the same problem, and the outgoing emails show one From address in the copy saved in my Sent folder and a different address in the email actually received by the recipient.

This sounds like a bug to me.

Helpful?

more options

k.s1 re:Do you mean to say that it is the intentionally designed behavior for Thunderbird to substitute the server login address for the From address chosen in the regular email user interface? It is not a bug. Thunderbird is not changing anything. It enters the From as you set up and It sends via the smtp email address you have set up. So, you need to check what server you are using to send emails. Thunderbird will use the setting you have chosen to use. But that smtp server may choose to alter the 'From' because you are relaying via that other email address.

Senario: If you have an email address called 'A' and it is not a gmail address, but you have set up that 'A' Account to send via a gmail smtp address, then if gmail allow the relay then you will discover gmail choose to enter the gmail address which you are using as the From email address. So if sending via gmail then at least make sure you include a 'Reply-to' the 'A' email address in the email or see if you can properly set up to allow the authentication of the 'A' email address when using the gmail 'B' to send.

My case example: I have an email address called 'A' but use my ISP email address 'B' as the outgoing smtp server. In my ISP email address webmail account, I have set up to allow the authentication of the 'A' email address. So the 'From' 'A' email address is still in the 'From' field which recipient will see, but if you read the full headers, you can see that there is an authenticated pass via the other ISP email address which is not hidden.

But the best and normal method is to allow account 'A' to send via account 'A' smtp server.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.