Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mailbox contents hover highlighting

  • 4 replies
  • 1 has this problem
  • 99 views
  • Last reply by sfhowes

more options

Just upgrade from TB 68 to 78. Everything looks okay so far, except for one new feature I do not like at all. When mouse hovering over the list of messages in a mailbox, the message under the mouse pointer is highlighted the same as if it had been selected. Is there any way to turn this off or to change the highlight color? It has already caused me to accidentally delete a few messages I did not intend to delete. I really don't like this "feature" and am considering going back to TB 68 if I can't find a way to disable it or alter its behavior.

Chosen solution

Thanks sfhowes. That's exactly what I was looking for. It took me a little fiddling with the back-ground color value to find something that agrees with my warped sense of style. But it's working now, and I'm happy with it. Many thanks!

Read this answer in context 👍 0

All Replies (4)

more options

The hover color can be eliminated with this userChrome.css:

treechildren::-moz-tree-row(hover) { background-color:  transparent  !important; }

To set the color, use this code:

treechildren::-moz-tree-row(hover) { background-color:  #dc0f0f  !important; }

#threadTree > treechildren::-moz-tree-cell-text(hover)
{color:white !important;} 

#folderTree > treechildren::-moz-tree-cell-text(hover)
{color:white !important;} 

treechildren::-moz-tree-row(hover) { border: none !important; }

The folderTree line applies the effect to the Folder Pane.

Help/Troubleshooting, Profile Folder, Open Folder, close TB, create a subfolder named chrome, create a new document in chrome with a text editor, name it userChrome.css, save as type: All files *.*, copy the code into the css file. Options/General/Config. editor, double-click toolkit.legacyUserProfileCustomizations.stylesheets to true, restart TB.

Helpful?

more options

Chosen Solution

Thanks sfhowes. That's exactly what I was looking for. It took me a little fiddling with the back-ground color value to find something that agrees with my warped sense of style. But it's working now, and I'm happy with it. Many thanks!

Helpful?

more options

Thanks for the question and the answer. I am so relieved. The solution from sfhowes worked for me (Thunderbird 78.4.1 running on Win 7 Pro, 32-bit). In my case, hovering over unread emails made them "disappear", i.e. the hover color was not blue but white. As I hovered down the list of new emails each disappeared and then reappeared as I moved on, resulting in chaos between my brain and eyes. How crazy is that and how crazy was I after a day or two of that happening. In the css file, I used the color #cccccc (light grey) and changed the text color from white to black. One more tip for the css-inexperienced like myself: after creating the css file, you have to reopen TB to go to the Options/General/Config.editor. There is a button at the bottom of the General section to change configuration.

Helpful?

more options

The hover bug in W7 is partially fixed in 78.4.3:

https://www.thunderbird.net/en-US/thunderbird/78.4.3/releasenotes/

but there may still be some anomalies for themes other than Basic.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.