Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Drafts Not Deleting

  • 9 replies
  • 1 has this problem
  • 358 views
  • Last reply by sfhowes

more options

Over the past week or so I've noticed that auto-saved drafts of emails I'm writing aren't being deleted when I send the email. I have to manually delete that draft.

Chosen solution

In the Copies & Folders section of Tools/Account Settings, set drafts to be stored in "Drafts" Folder on: Local Folders. You shouldn't need to create a Drafts folder manually.

Read this answer in context 👍 1

All Replies (9)

more options

Still no response to this. Sometimes I have as many as three drafts for a particular email.

more options

Is the Drafts folder on an IMAP server or in Local Folders? If it's the former, try changing to the latter. Tools/Account Settings, Copies & Folders.

more options

sfhowes thank you very much for your reply. The Drafts folder is on the IMAP server. This issues showed up recently - after an upgrade to Thunderbird. It had been working fine before.

more options

Do you have a security app acting on the TB profile folder? It's possible the drafts behavior changed when TB updated and the security app became incompatible. In any case, unless you need to access drafts on other computers, it's best to store them in Local Folders.

more options

sfhowes - I have the same security now as I did when it was working - Trend Micro with Folder Shield turned on.

I create a Drafts in Local Folders, but I don't know how to point the Drafts from the IMAP folder to that one.

more options

Chosen Solution

In the Copies & Folders section of Tools/Account Settings, set drafts to be stored in "Drafts" Folder on: Local Folders. You shouldn't need to create a Drafts folder manually.

more options

Thanks sfhowes. That did it. I appreciate all of your help.

more options

I have a different problem in that I have already set my Drafts to go to my Local Folders. But for some reason, Thunderbird (version 78.7.1) keeps reverting the Draft setting back to the Other: Draft on to my Proton and Gmail accounts.

I am running ProtonMail with Proton Bridge and I also have Gmail accounts on Linux. I have tried to save this setting multiple times and every time I exit the program and relaunch Thunderbird, the settings that I have modified are not saved.

Just to check, there isn't any Apply button on the Setting page so I just exit the Setting page. What am I doing wrong?

more options

You should try with a new profile without a Proton account or ProtonBridge, as I would suspect it is the reason the drafts setting is not maintained.