Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't connect to Yahoo IMAP & SMTP servers (TB 78.4.0 & TB 68.12.1)

  • 9 replies
  • 2 have this problem
  • 1388 views
  • Last reply by atErik

more options

Since today I can't access my Yahoo IMAP and SMTP servers, neither with TB 78.4.0 nor TB 68.12.1. The access to Yahoo's POP3 servers is possible as I have still one Yahoo e-mail account which uses POP3 server.

Yahoo had announced that they will restrict the access to their e-mail servers for "outdated Apps", but to Thunderbird this restriction should not apply.

Things I've done so far:

  • allowed cookies in "Privacy & Security" (was already set)
  • deleted all old passwords
  • tried to change authentication method to OAuth2 both on IMAP and SMTP servers, worked for the IMAP servers only

The following errors occur:

  • TB just says "Couldn't connect to server imap.mail.yahoo.com", and that's it. No "Enter password for server XYZ" dialog is shown
  • I can't change the authentication method for SMTP servers to "OAuth2", the option is not shown in the drop down list
  • since one of my Yahoo e-mail accounts (which is accessable via POP3) is working with TB, I've tried to access my other Yahoo accounts via POP3 servers instead of IMAP servers, but failed

I would be grateful for any help and ideas.

Chosen solution

Hi all,

the issue is finally solved!

I've activated "DNS over TLS" (DoT) in my router recently, this caused the issue with the OAuth2 browser window not showing in TB.

In order to get TB working properly with OAuth2 I had to activate "DNS over HTTP" in TB's network connection settings.

Phew ... that was a long and bumpy ride ... ;-)

Read this answer in context 👍 1

All Replies (9)

more options

TB 78.4 was supposed to automatically migrate Yahoo accounts to OAuth2 authentication, but if it isn't working, you can set the smtp authentication manually:

https://support.mozilla.org/en-US/questions/1309104#answer-1359490

After the authentication is set to OAuth2 for all Yahoo incoming and outgoing servers, remove all Yahoo items in Saved Passwords again, restart TB, and enter the regular account password in the OAuth browser window when prompted.

Helpful?

more options

Hi sfhowes,

many thanks for you reply.

The problem is that the OAuth2 browser windows isn't shown for the IMAP servers when TB is restarted. Javascipt is enabled, I've checked that.

When I try to send an e-mail from one of my Yahoo e-mail accounts the OAuth2 browser window pops up and I can enter the credentials for the SMTP server. But that does not help for the IMAP servers. Even after removing the Yahoo e-mail accounts completely and creating this accounts new there's no OAuth2 browser window showing.

But after installing TB on a different machine from scratch I was able to create the Yahoo e-mail accounts properly with working OAuth2 access to both IMAP and SMTP servers.

I suppose that TB has problems with Yahoo accounts and/or OAuth2 in existing profiles.

Helpful?

more options

Addendum:

I've just ran in an "Programming bug" while trying to create a new Yahoo e-mail account in TB. After restarting TB, the OAuth2 browser window showed for one of my Yahoo e-mail accounts and I could enter the credentials. I was able to access this account once, then it stopped working again and keeps showing the "Couldn't connect to server imap.mail.yahoo.com"

Weird ...

Helpful?

more options

Try disabling you anti virus scanner from scanning secure connections. Ensure Thunderbird is accepting cookies. They are integral to oAuth functionality.

Helpful?

more options

Hi Matt,

no anti virus scanner is installed, cookies are accepted, Javascript is enabled.

And it's working, at least sometimes, because when sending an e-mail from one of my Yahoo accounts the OAuth2 browser window is shown and I can enter my credentials for the SMTP server. Unfortunately it's not working for the IMAP servers.

Helpful?

more options

Chosen Solution

Hi all,

the issue is finally solved!

I've activated "DNS over TLS" (DoT) in my router recently, this caused the issue with the OAuth2 browser window not showing in TB.

In order to get TB working properly with OAuth2 I had to activate "DNS over HTTP" in TB's network connection settings.

Phew ... that was a long and bumpy ride ... ;-)

Helpful?

more options

I cannot find a setting called "DNS over TLS" (DoT). Is this one of the Connection Security choices? I'm using TBird 60.9.1 Would this option appear in TBird only when the router is set for that method?

I just created a POP account a couple days ago, and after creating an App Specific Password & allowing cookies, using their default Ports, it downloaded the existing mail and I could SEND a test message. But after that one download, downloads fail with the message: > Sending of password for user XXX@yahoo.com did not succeed. Mail server pop.mail.yahoo.com responded: Server error - Please try again later. >

Wonder if pop.mail.yahoo.com server is just down, they are famous for that. According to IsItDownRightNow.com , it is.

Helpful?

more options

Go to to "Server settings" for your Yahoo account. Under "Security settings" choose OAuth2 for authentication. Hopefully when it tries to connect the next time, you will go though a login process and everything is tickety boo henceforth

Helpful?

more options

https://stackoverflow.com/a/63255601/3553808 : Access WebMail Type Of Email-WebSites From TB-WebBrowser-Tab , or , Configure TB to allow very specific OAuth2 based website-addresses in TB's Cookie-Exception list, etc, etc. (please upvote my Q+A both, inside the linked page, if its useful/helpful).

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.