Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address bar search and suggestions not working

more options

I updated firefox with the Update Manager in Linux Mint to version "82.0+linuxmint4+ulyana".

The address bar doesn't give any suggestions (for example when partially typing "you", "youtube.com" used to show up) and search doesn't go to google search anymore. If I enter just one word as the search term and press enter, it takes 5-6 seconds and I am taken to that website (for example searching "facebook" takes me to facebook.com). Searching something gibberish like "asdasd" takes me to a page to buy that domain). Searching something with a space in it like "asd asd" and pressing enter doesn't do anything. Even clicking the "Go" arrow doesnt do anything.

My history is there in the histroy tab and all the suggestions options in preferences are already set.

Chosen solution

I upgraded to Firefox 82 again. I was about to do the steps @cor-el suggested, but the problem was somehow fixed itself. Marking as solved.

Read this answer in context 👍 0

All Replies (3)

more options

I reinstalled Firefox completely (I synced everything, 'apt purged' firefox (uninstall and remove all configuration), backup up then removed ~/.mozilla, and installed Firefox 82) Still, the same problem was there.

Then I did the same things but instead installed Firefox 81 and everything works as before. Possible bug in Firefox 82.

Helpful?

more options

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

This can be caused by a problem with the places.sqlite and favicons.sqlite databases in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox or reboot and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder with Firefox closed. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

more options

Chosen Solution

I upgraded to Firefox 82 again. I was about to do the steps @cor-el suggested, but the problem was somehow fixed itself. Marking as solved.

Modified by prateek.saini.1999

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.