Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Security protocol error when sending emaila

  • 13 replies
  • 1 has this problem
  • 108 views
  • Last reply by jscher2000

more options

I installed the latest version 81.0.2 - I WISHED I haden't When sending Emails I get-: 'Thunderbird can't connect securely to website.mozilla.org because the site uses a security protocol that isn't enabled'

Now then, I use exactly the same set up on two other computers but with a older Firefox but all with exactly the same Email versions of an ealier Thunderbird.

Question 1. How the blazes can I stop this error?

Question 2. Why is it that I have to answer Cookie permissions before going to a web site.

Question 3. How the hell do can you turn Google search suggestions off - YES, I have search suggestions disabled! The only sure way is to block them with ADblock - WHY can't it be done in Firefox, paying a sum are they?

EDIT: The link should read-: website-archive.mozilla.org

Dave

Modified by EF80

Chosen solution

EF80 said

It comes up as soon as I click the Thunderbird icon at the same time as the Email screen.... I can then continue as normal until I close the Email screen, the Emails work as normal, it happens when I tried updating to the latest Thunderbord version.

Hi David, since the problem appears to be the mail start page (Thunderbird's "home page"), try changing it to a different URL or your choice, or blank it by unchecking the option to load a mail start page. Details are in this article: How to disable or change the Thunderbird start page.

Read this answer in context 👍 1

All Replies (13)

more options

Hi Dave,

Question 1

If you are composing and sending a message in Thunderbird, I don't know why there would be an error related to a Mozilla website. Since this thread is on the Firefox forum, you may want to create a separate post about Thunderbird issues:

https://support.mozilla.org/questions/new/thunderbird

Question 2

A lot of websites get visitors from countries that require them to collect consent to use cookies or at least give notification of cookies being used. I assume you mean one of those types of messages, and not a message from Firefox itself.

Firefox doesn't filter these website features but of course there are add-ons for that. For example:

https://addons.mozilla.org/firefox/addon/i-dont-care-about-cookies/

Question 3

Firefox has settings for dynamic search engine suggestions provided in the drop-downs for Firefox bars:

  • address bar
  • optional search bar for the main toolbar
  • search bar in the Firefox Home / new tab page

More information on that in this article: Change your default search settings in Firefox.

If you are referring to suggestions that a web page generates within itself, these are not filtered by Firefox. As you say, add-ons can suppress those site features if you do not want to see them.

Helpful?

more options

I'm sorry jscher2000, I DO beleive it is a Firefox issue.... I use exactly the same Thunderbird set up, the same version - the lot on two other machines and it just does not happen BUT on them I use a older Firefox, NOW can you see why I've posted here?

I will prove a point later, I will remove Firefox 81.0.2 I will 'scour' the hidden files and registery and clean the whole lot out! If you are right in that it is a Thunderbird Issue it SHOULD STILL happen - right..... and if it doesn't then what?

Sorry I'm really getting 'narked' with Firefox and their persistant ways.

Dave

Helpful?

more options

Hi Dave, where is the error message being displayed? Within Thunderbird or within Firefox? Can you provide a screenshot of it?

Also, what is the real address? website.mozilla.org is not a real Mozilla server address.

Helpful?

more options

jscher2000, thank you for the reply - well, I'm looking a right fool here-:

It was in Thunderbird clear as day....'Thunderbird can't connect securely to website.mozilla.org because the site uses a security protocol which isn't enabled.' I can't show you a screenshot because it's GONE...! Could I just quote.... because the site uses a security protocol which isn't enabled. This probably added to my confusion here. BTW I'm running Win 7 pro x64 bit.

Installing anything like this I always 'reboot', I tried several times and this warning kept popping up but yet I could still send and receive Emails and now...... it's all gone, I don't get thit anymore, so I'm nearly happy apart from these 'pesky cookie permission' pop ups, I've always had Firefox to do a clean out before closing.

I'll try the new Firefox update for a day or two now and decide after I re-established this machine I've done a clean install on with SSD's.

Thank you for your time. Dave

Helpful?

more options

The darn things back.... WHY do I not get the error on when using a older version of Firefox?????? The error is-:

Thunderbird can't connect securely to website-archive.mozilla.org

Yet the emails send and receive OK, it only started to happen when I upgraded Firefox, I have tried various protocol settings... thius IS CLEARLY a Mozilla issue not a Thunderbird issue since the emails run OK, it seems to be something thats not letting Thunderbird communicate wir Archive.mozilla link IN FIREFOX.

I get no such message on other computers that runs earlier versions of Firefox uaing the same Email set up.

Dave

Helpful?

more options

Hi Dave, I don't know why your Thunderbird is trying to connect to that address. Keep in mind that Mozilla created both Firefox AND Thunderbird. Now Thunderbird is more independently managed but there is still some infrastructure shared.

I'm going to flag this thread to move over to the Thunderbird board where perhaps someone will know why these addresses are being mentioned.

You can assist further by explaining where this message appears. For example, when you first start Thunderbird, before selecting a message to preview, there may be a default page displayed in the preview pane. Is that where the problem appears?

Helpful?

more options

See image - sorry about the quality.

The message appears on Thunderbird screen - yet I can send and recived Emails 'no problem', I have two other computers with the same set up and an older version of Firefox and it DOES NOT HAPPEN.... it even happens when I updated Thunderbird

The two machines are Win7 x32bit and this problematic machine Win7 Pro x 64 - I even run XP pro and it does not happen.

Could you provide a link for the thread?

I am about to give up on Mozilla and Thunderbird if this is carries on, I'm losing faith rapidly.

Dave

Helpful?

more options

Hi Dave, your picture is very zoomed in so it's difficult to understand the context.

When does that dialog pop up -- when you hit Send on a message? Or for each Send/Receive cycle? Or at startup?

Based on various searches, it seems that address was used for release notes for much older versions of Thunderbird . It's rather mystifying why a version of Thunderbird released in the past five years would want to connect to it.

https://www.google.com/search?q=site%3Awebsite-archive.mozilla.org+thunderbird

Helpful?

more options

The link I gave should read <website-archive.mozilla.org>

It comes up as soon as I click the Thunderbird icon at the same time as the Email screen.... I can then continue as normal until I close the Email screen, the Emails work as normal, it happens when I tried updating to the latest Thunderbord version.

It does not happen on other computers with the same Email app. but with Firefox 72 versions AND I have tried different protocols with the same result - it only started on this when I updated to Firefox 81.0.2

Now can you understand why I say it's a firefox issue?

I am getting entirely sick of Mozilla escapades - updating every 6 months AND FORCING UNWANTED UPDATES - It's time for me to ditch Mozilla and Thunderbird altogether..

Can someone at Mozilla EXPLAIN how to stop these updates????? I am now getting annoyed at these antics!

David!

Modified by EF80

Helpful?

more options

Chosen Solution

EF80 said

It comes up as soon as I click the Thunderbird icon at the same time as the Email screen.... I can then continue as normal until I close the Email screen, the Emails work as normal, it happens when I tried updating to the latest Thunderbord version.

Hi David, since the problem appears to be the mail start page (Thunderbird's "home page"), try changing it to a different URL or your choice, or blank it by unchecking the option to load a mail start page. Details are in this article: How to disable or change the Thunderbird start page.

Helpful?

more options

Yeah....! It works.

Good man jscher 2000, now why didn't 'I' think of that.... probably mi' brains cells were on vacation uh? I never even thought about looking at the start page in 'options', I just scrubbed the address out.

I'm happy again thanks to you, thank you for your time, perseverance and great patience.

Dave

Helpful?

more options

Their (not so) smart filter just dumped my post COMMENTING about brave dot com

Modified by neilw20

Helpful?

more options

neilw20 said

Their (not so) smart filter just dumped my post COMMENTING about brave dot com

If you didn't post a spammy link or scammy phone number, your post should appear after moderation.

I don't know how brave dot com will help with Thunderbird, though.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.