Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot send email with smtp.office365.com

  • 11 replies
  • 2 have this problem
  • 1908 views
  • Last reply by wildstan

more options

I was connected to O365 with my work email but cannot send any message. IMAP works just fine, all folders synced regularly, but sending not work for some unknown reason.

SMTP setting is as follow: smtp.office365.com port 587 STARTTLS OAuth (this is correct setting, all others shows errors, including outlook.partner.cn & smtp.office365.cn, which is completely normal since I'm not in China).

The first thing that jump out is that my password is not OK, which is not correct. Password is OK. Click on "Retry" or "Enter new password" do nothing, just return the same pop up. If "Cancel", then receiving message with "unknown error 80004005" and all other blablabla about unknown reasons, with instruction to check my SMTP settings.

I've tried all variations available, but nothing works. Sometimes, at some moment after click on Cancel, it said "Message sent" and I can see it in my Sent Items folder, but it's fake because I never receive that test message to my personal Gmail address.

I have already tried all suggestions I could find (deleting passwords, resetting all, restarting, deleting and adding account again, changes in Config editor related to security.tls), but nothing worked for me.

My OS: Win 10 Pro, build 2004, TB version 78.3.2

Any advise is very welcome. Thank you all in advance.

Chosen solution

I have this problem, too. But, I am running Windows 10.

So, the suggested solution wouldn't apply.

It all worked until Microsoft installed a WIndows update; since then email can't be sent any longer.

I am so tired of them messing around; they just don't understand customer CARE.

Any help from anybody would be appreciated.

Read this answer in context 👍 0

All Replies (11)

more options

SOLVED!

Thanks to Microsoft's O365 Ambassador Mr. Chima, this problem was solved. At least - it works in my case.

What to do:

1. Go to your O365 Admin panel > click Show all... to expand left menu > Under Admin centers go to Exchange > then click on hybrid.

2. Download the second Configuration (The Exchange Online PowerShell Module supports multi-factor authentication. Download the module to manage Exchange Online more securely.), then Install this module on affected computer (module's name: Microsoft.Online.CSE.PSModule.Client.application)

3. Run installed module as administrator from Desktop (if wont start, go to Start, in the search field type Exchange, than choose Microsoft Exchange Online PowerShell Module and Run as administrator).

4. Once the PowerShell panel is opened enter the following command (for yourname@your.domain enter affected e-mail address): Set-CASMailbox -Identity yourname@your.domain -SmtpClientAuthenticationDisabled $false

5. Press Enter and wait a little bit to command implement.

6. When the new command line shows up, it's done.

7. Restart Thunderbird and try to send e-mail.

Good luck!

Modified by denexi

more options

Nope... not solved...

Only 1 laptop started to work with this solution (I have o idea why), all others not (I also have no idea why, since all has the same settings).

So, this case is still open and waiting for any suggestion or solution from Thunderbird... Hopefully soon....

more options

It is solved now.

So, the main problem is related to O365 Basic security. This must be disabled in O365 Admin center and Advanced Security must be activated for all users. This is for those who use MFA and OAuth2. My Windows version: 10 Pro x64, build 2004 TB version: 78.4

Steps to solve this: 1. Activate Advanced Security and by that automatically disable Basic Security in O365 Admin center 2. Sign-out affected user from all devices via Admin center 3. Disable MFA for affected user (if enabled or enforced), then just Enable it back (nothing else) 4. Upgrade TB to the latest version 78.4.0 5. Remove previously added O365 email account from TB 6. Delete Saved passwords for that account and close TB 7. Go to Windows firewall and add TB as allowed into Inbound and Outbound rules 8. Open PowerShell as admin and force TLS 1.1 and TLS 1.2 by these syntax: 8.1. [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls11 (enter to execute) 8.2. [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12 (enter to execute) 9. Open Command prompt and test ping for smtp.office365.com (if get replies, it's OK) 10. Open TB and set new email account with following (enter all requested data, including to check "Remember password"), then click Continue. If account was found, click on Manual settings and there check/set as follows: IMAP data: outlook.office365.com; SSL/TLS; Port 993; OAuth2; full email address as username SMTP data: smtp.office365.com; STARTTLS; Port 587; OAuth2; full email address as username Click on "Re-test". If no errors, click "Done". Restart TB.

11. Open TB again and login using Authentication. 12. Try to send email. If work (for me this procedure worked for 10 computers) - great! If not - firstly wait a little bit because re=setting in Admin panel need some time to become active again, sometimes more then 30 min.

12. If not work even after 30 min., try with previously mentioned Hybrid module where will enter following syntax: Connect-EXOPSSession -UserPrincipalName your@email.com (your@email.com replace with affected email address). Restart computer and try to send email again.

Good luck.

more options

Chosen Solution

I have this problem, too. But, I am running Windows 10.

So, the suggested solution wouldn't apply.

It all worked until Microsoft installed a WIndows update; since then email can't be sent any longer.

I am so tired of them messing around; they just don't understand customer CARE.

Any help from anybody would be appreciated.

more options

Here a solution that solved the problem for me :

You must be an Office 365 admin. Open the Microsoft 365 Admin Center (web page) and go to Users > Active users. Select the user, in the properties of the user panel click Mail. In the Email apps section, click Manage email apps.

In this panel, you have several items like Outlook on the web, Mobile (Exchange ActiveSync), POP, IMAP, Authenticated SMTP, … All items were checked for me. Uncheck the Authenticated SMTP item, then click on Save. Check back the Authenticated SMTP item, then click on Save.

Wait a moment (30 sec for me) and the problem is solved: sending email with SMTP is working with Thunderbird.

Modified by Vincent

more options

Vincent,

I have spent two days googling this issue and making adjustments without success but now smtp mail works: )

I migrated 3x M365 Kiosk mailboxes to Exchange Online at the weekend and one of them is used by a payroll app. . . . that app. was unable to send smtp.

Thank you.


M365 | Exchange Online | Win 10 Pro

more options
more options

The same SMTP problem is back for me few days ago. But it works again with the following SMTP setting :

   server: smtp.office365.com
   port: 587
   Security: STARTTLS
   Method: OAuth2
   User: (my full email address)

My previous config was « Method = Normal password». And it worked from December 2020 to January 2021. Now the config above is working.

It looks like Microsoft is upgrading their Exchange Servers at different time for each client, so a given solution is not working for everyone.

more options

The same SMTP problem is back few days ago for me. It worked again with the following SMTP setting at Thunderbird :

   Server: smtp.office365.com
   Port: 587
   Security: STARTTLS
   Authentication method: OAuth2
   User: (my full email address)
   

My prevous configuration was « Authentication method: Normal passord ». This worked from December 2020 to Januray 2021. Now working config is « Authentication method: OAuth2 ».

It looks like Microsoft is upgrading its Exchange Servers with a different timing for each client. Thus a given solution is not working for every one at a time.

more options

FYI: For me enabling the SMTP-authentification by setting option -SmtpClientAuthenticationDisabled to false wasn't enough. It seems I also had to change weak initial-password for exchange-mailbox to a new strong password (imap access was not affected by this problem).

I can't say for sure, but it's possible that accounts with initial-passwords or weak passwords are excluded from using smtp-auth (at least in some exchange-server configurations). Maybe you should take it into consideration when you're facing this issue.

edit: did some changes; what I wrote before was a bit confusing.

Modified by wowbagger

more options

Hi everybody.

I had the same problem, I couldn't send letters via SMTP, via Thunderbird.

I just had a call with O365 supportman, and he told me that it is caused by enabled MAPI. I disabled it and everything flied.

P.S.: here is the script to disable mapi for all the users

Get-CASMailbox -Filter {ImapEnabled -eq "true" -or PopEnabled -eq "true" } | Select-Object @{n = "Identity"; e = {$_.primarysmtpaddress}} | Set-CASMailbox -MapiEnabled $false